locked
SharePoint Designer 2007 Workflow ACCESS DENIED RRS feed

  • Question

  •  Our environment has three web applications lets call them a, b, and c. The SharePoint Designer 2007 workflows are running fine on web application a and b. The web application C workflows gives an Access Denied when manually starting a SPD 07 workflow. Well for that matter even the start when x changes is not running. I have read and tried almost everthing, below is a list of what I have tried,

    1. Check in / out Workflow folder.

    2. Create a new list / add a new workflow.

    3. Create a new site collection / content database.

    4. Log in as a service account, my account, site collection administrator account.

     The work flow has been running fine for two years. Just in the last five day's has the Access Denied been showing up.  I looked in the logs and this is what is coming up. 

    w3wp.exe (0x2420) 0x31C0Windows SharePoint Services   	      General     72nz	  Medium  	Videntityinfo::isFreshToken reported failure.
    OWSTIMER.EXE (0x1D44) 0x1888	Windows SharePoint Services   General     8kh7	  High    	The user does not exist or is not unique.
    w3wp.exe (0x18E8)     0x1830	Windows SharePoint Services   General     8kh7	  High    	Access denied.	

     I did find that after creating a SPD 07 workflow and then trying to edit I get access denied.

     Is there a place that explains the SPD 07 workflow access model. Or ..

     How about SPD Workflow path (services) used in a web application??

    


    R/ Art M


    • Edited by Arthur M Friday, September 27, 2013 1:11 PM
    Thursday, September 26, 2013 4:19 PM

Answers

  • Hi Arthur M,

    Do you mean that the Designer workflows are not able to start on the whole web application? Or just one workflow meet access denied.

    Would you please try the built in approve workflow in the list, check whether it can be started? From the error message, it should be a permission issue, add a new user to site with edit permission, use the user to create/edit/start the workflow, check the result.

    If it isn’t the issue, please feel free to let me know.

    Thanks,

    Qiao

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Qiao Wei
    TechNet Community Support

    Monday, September 30, 2013 7:51 AM
    Moderator

All replies

  • 
    I've reset the password on the app pools, recycled and restarted the website in IIS.  
    I've verified that the SPServices account is in the WSS_WPG group on all three servers.  
    I attempted the workflow a dozen times and then traced the errors back to the security log on the server showing two failures each time:
    **********************************************************
    Event Type:	Failure Audit
    Event Source:	Security
    Event Category:	Logon/Logoff 
    Event ID:	537
    Date:		9/26/2013
    Time:		10:01:44 AM
    User:		NT AUTHORITY\SYSTEM
    Computer:	************
    Description:
    Logon Failure:
     	Reason:		An error occurred during logon
     	User Name:	
     	Domain:		
     	Logon Type:	3
       	Workstation Name:	-
     	Status code:	0xC000006D
     	Substatus code:	0x0
     	Caller User Name:	-
     	Caller Domain:	-
     	Caller Logon ID:	-
     	Caller Process ID:	-
     	Transited Services:	-
     	Source Network Address:	-
     	Source Port:	-
    **********************************************************
    **********************************************************
    Event Type:	Failure Audit
    Event Source:	Security
    Event Category:	Logon/Logoff 
    Event ID:	529
    Date:		9/26/2013
    Time:		10:01:44 AM
    User:		NT AUTHORITY\SYSTEM
    Computer:	**********
    Description:
    Logon Failure:
     	Reason:		Unknown user name or bad password
     	User Name:	
     	Domain:		
     	Logon Type:	3
     	Authentication Package:	Kerberos
     	Workstation Name:	*********
     	Caller User Name:	*********
     	Caller Domain:	IPADS
     	Caller Logon ID:	(0x0,0x3E7)
     	Caller Process ID:	528
     	Transited Services:	-
     	Source Network Address:	-
     	Source Port:	-

    

    R/ Art M


    • Edited by Arthur M Thursday, September 26, 2013 7:58 PM
    Thursday, September 26, 2013 7:56 PM
  • http://msdn.microsoft.com/en-us/library/bb862916(v=office.12).aspx

    Try that URL to look for services...

    Yes I am updating my request, just in case someone else is as unlucky as I am... 


    R/ Art M

    Friday, September 27, 2013 1:39 PM
  • Hi Arthur M,

    Do you mean that the Designer workflows are not able to start on the whole web application? Or just one workflow meet access denied.

    Would you please try the built in approve workflow in the list, check whether it can be started? From the error message, it should be a permission issue, add a new user to site with edit permission, use the user to create/edit/start the workflow, check the result.

    If it isn’t the issue, please feel free to let me know.

    Thanks,

    Qiao

    Forum Support

    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Qiao Wei
    TechNet Community Support

    Monday, September 30, 2013 7:51 AM
    Moderator