locked
Error when adding trusted locations to infopath 2010 RRS feed

  • Question

  • The trusted location list for my infopath installation does not contain any folders, which itself is odd to begin with.

    Whenever i try to add a location on my computer ( c:\ , c:\ somefolder etc) It keeps saying , the path you have added is not valid or cannot be added for security reasons!! 

    Could some one tell me whats going on?Thank you 


    Arun
    Monday, November 1, 2010 5:30 AM

Answers

  • Nah, definitely not the same thing.  Excel Services trusted file locations are a feature in Central Admin - in the Service Application settings for Excel Services.  That is a farm setting.  What you're talking about is a local InfoPath setting.  I've never seen that used for InfoPath.  What you're dealing with is an issue with using your local machine, I believe.  InfoPath considers your connection as being across domains even though they are both locally hosted.  You are supposed to publish to a network location, so can you put both the database and published form template on a shared network location, then try it again?

    The error you're getting is a common "pain in the rear" message that I've also gotten when the error itself wasn't true, but there was an issue with communication of the form to the publish location and data connections.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Wayne Fan Thursday, November 11, 2010 1:16 AM
    Monday, November 1, 2010 9:16 PM

All replies

  • What is a trusted location for InfoPath 2010?  I've never heard of that nor have I had to use one before.  I only know of trusted file locations for Excel Services.
    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Monday, November 1, 2010 3:38 PM
  • It works the same way for infopath, you can set trusted locations under File->options->Trust centre.

    The reason i am fiddling with these settings is cause i am having trouble with a published form connecting to an access database. I created the form using the "database" template and i published it to the same folder as the database but every time i fill it and submit i get a "Accessing data across domains is not supported for forms opened from the Internet" message. So i was trying to see if i should add that folder as  a trusted location. 

     



    Arun
    Monday, November 1, 2010 8:20 PM
  • Nah, definitely not the same thing.  Excel Services trusted file locations are a feature in Central Admin - in the Service Application settings for Excel Services.  That is a farm setting.  What you're talking about is a local InfoPath setting.  I've never seen that used for InfoPath.  What you're dealing with is an issue with using your local machine, I believe.  InfoPath considers your connection as being across domains even though they are both locally hosted.  You are supposed to publish to a network location, so can you put both the database and published form template on a shared network location, then try it again?

    The error you're getting is a common "pain in the rear" message that I've also gotten when the error itself wasn't true, but there was an issue with communication of the form to the publish location and data connections.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    • Marked as answer by Wayne Fan Thursday, November 11, 2010 1:16 AM
    Monday, November 1, 2010 9:16 PM
  • Arun,

    If you are only attempting to use the 'local' data source as part of the development effort, there is another easy fix...

    With the offending form open in InfoPath 2010:

    1. Navigate File -> Advanced form options -> Security and Trust
    2. Change security level to 'Full Trust'

    Prior to publishing, be sure and raise this setting to a more secure one, but you now can do form previews without encountering the domain error messages.

    Cheers!

    • Proposed as answer by XristosK Tuesday, February 22, 2011 11:52 PM
    Friday, November 12, 2010 7:11 PM