locked
data access library v4.1 RRS feed

  • Question

  • User65893105 posted

    Ive just started a project that will use the enterprise library 4.1 data access code blocks.  Its been years since ive used them, can anyone tell me what assemblies I need to reference in my project in order to use them ?  Ive referenced 


    Microsoft.Practices.EnterpriseLibrary.Data


    are there any others I need ?

    Friday, July 30, 2010 10:47 AM

Answers

  • User-245554983 posted

    hi misuk11,

    It is a mistake from me, Microsoft.Practices.ObjectBuilder was required with initial version. With 4.1 you will need only Miccrosoft.Practices.EnterpriseLibrary.Data and Miccrosoft.Practices.EnterpriseLibrary.Common.

    Please accept my apology for this inconvenience.



    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 2, 2010 9:37 AM

All replies

  • User-245554983 posted

    hi misuk11,

    Along with Miccrosoft.Practices.EnterpriseLibrary.Data you will need the following:

    1. Miccrosoft.Practices.EnterpriseLibrary.Common

    2. Miccrosoft.Practices.ObjectBulider

    Thanks

    Please mark as answer if it is helpful


    Friday, July 30, 2010 11:26 AM
  • User65893105 posted

    should that be Microsoft.Practices.ObjectBuilder2  ?  there isnt a microsoft.practices.objectbuilder file

    Monday, August 2, 2010 4:42 AM
  • User-245554983 posted

    hi misuk11,

    It is a mistake from me, Microsoft.Practices.ObjectBuilder was required with initial version. With 4.1 you will need only Miccrosoft.Practices.EnterpriseLibrary.Data and Miccrosoft.Practices.EnterpriseLibrary.Common.

    Please accept my apology for this inconvenience.



    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, August 2, 2010 9:37 AM