locked
Data Not inserting into table at end of SSIS package RRS feed

  • Question

  • I have a very simple SSIS package that at the end the data is inserted into a SQL table.  The package runs, and says that it is successeful (everything turns green), but the data is not being inserted in the table.  It is also not giving me any errors in the log to tell me why the data is not being inserted.

    I have added a data viewer to the link before the insert, and it is showing the data in the viewer, so I know what it looks like before going into the table.  All of the data appears to be present and correct.

    Does anyone have any suggestions as to why the data may not be inserted, and the SSIS package is showing as completed successfully?

    Thanks!
    Tuesday, October 6, 2009 4:07 PM

Answers

  • because you mentioned that you have checked every thing .

    delete the OLE Object , save pacakge and open again and add the OLE again
    Sincerely SH -- Please kindly don’t forget to mark the post(s) that answered your question and/or vote for the post(s)
    Tuesday, October 6, 2009 4:54 PM

All replies

  • what object are you using? and what is the settings

    try OLE Destination


    Sincerely SH -- Please kindly don’t forget to mark the post(s) that answered your question and/or vote for the post(s)
    Tuesday, October 6, 2009 4:14 PM
  • Are you using SQL Destination?
    Please provide details of ur package.
    Hope this helps !!
    Sudeep      My Blog
    Tuesday, October 6, 2009 4:19 PM
  • I am using OLE DB Destination.  I have triple checked all of the settings, and I do have rights to insert into the table in question.  I have even created a log file to log everything, and the line at the end says:

    "component "OLE DB Destination" (5593)" wrote 2607 rows.
    Tuesday, October 6, 2009 4:27 PM
  • because you mentioned that you have checked every thing .

    delete the OLE Object , save pacakge and open again and add the OLE again
    Sincerely SH -- Please kindly don’t forget to mark the post(s) that answered your question and/or vote for the post(s)
    Tuesday, October 6, 2009 4:54 PM
  • I am using OLE DB Destination.  I have triple checked all of the settings, and I do have rights to insert into the table in question.  I have even created a log file to log everything, and the line at the end says:

    "component "OLE DB Destination" (5593)" wrote 2607 rows.
    Nik is correct here.
    OR
    Try with New package once again.
    Thanks-
    Let us TRY this | Don’t forget to mark the post(s) that answered your question
    Tuesday, October 6, 2009 6:28 PM