locked
Unable to administer IIS 7 RRS feed

  • Question

  • User-606311767 posted

    I have currently upgraded my laptop to Windows Vista Ultimate.  I have had a few slight issues with it but have overcome them all except for administrating IIS 7.  My local user account is an administrator and when I open IIS Manager I run as Administrator, but I am still unable to administer the default application pools or web sites, much less create any new ones.  Every time I try I get the same error message:

    Access is Denied: (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))

    I have been researching this since I installed vista and since I am a Web Applications developer not being able to create websites is a big problem.  Can someone help?

    Thanks,

    Friday, May 4, 2007 3:58 PM

Answers

  • User511787461 posted
    You need to right click on IIS Manager and choose "run as administrator" - on vista, even users of admin groups have their admin access disabled by default, search for UAC to learn more about this - if this still does not solve the problem, use process-monitor from sysinternals to figure out what resource you are getting access-denied on.
    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Friday, May 4, 2007 5:08 PM