none
Target computer hangs after setting 'bcdedit /debug on' and reboot RRS feed

  • Question

  • Hi,

    I have two computers, one is target computer (Z8300) and the other is host computer (intel core i7).

    Both of them are Windows 10. (Target computer is Windows 10 Enterprise Evaluation and the other is home edition).

    After verifying NIC and USB on target computer, 'Serial port' seems the only solution I can use for debugging.

    (I am sure that I use 'NULL-Modem Cable Wiring).

    During the process of setting up the target computer, I follow the guide of https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/setting-up-a-null-modem-cable-connection.

    After setting 'bcdedit /debug on' and reboot the target computer, the system is freeze on spinning dots.

    (Spinning dots is freezed as well).

    I also tried to set 'noumex' and '/start' to be AUTOENABLE but it cannot help.

    I also confirmed that Boot Security in BIOS is disabled and BitLocker in Windows 10 is also enabled.

    I don't know what I can do because I am newer in driver programming.

    I tried to see if there is any 'log' in Windows system but I cannot see any log relates to this freeze issue.

    The only 'Error' I can see in EventViewer is :

    Event 1006, DistributedCOM.

    It said :

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID Window.SecurityCenter.WscBrokerManager and APPID Unavailable to the user NT AUTHORITY\SYSTEM SID (S-1-5-18) from address LocalHost (Using LRPC) running in the application container Unavailable SID (Unavailable). This security permission can be modified using the Component Services administrative tool.

    Please help to advice if anything I can do.

    Regards,

    Tonie

    Wednesday, September 26, 2018 6:00 AM

All replies

  • Is there any output from the debugger?

    With kind regards
    Wednesday, September 26, 2018 8:28 AM
  • Hi, 

    What is the Debugger ? Do you mean windbg ?

    I launched windbg in host computer and it always show

    'Opened \\.\com3
    Waiting to reconnect...'
    and nothing happend.

    One more question about the serial cable I am used.

    In my target computer, I use USB2COM cable.

    And all usb ports on my target computer cannot be used as debug port. (I use usbview.exe to check)

    Is this the root cause my OS is freezed ?


    • Edited by ToniePCP Wednesday, September 26, 2018 10:29 AM
    Wednesday, September 26, 2018 10:28 AM
  • For a com port for debugging you have to have a legacy serial port on the target.   You are going to have investigate network debugging, or else using a virtual machine.


    Don Burn Windows Driver Consulting Website: http://www.windrvr.com

    Wednesday, September 26, 2018 1:09 PM
  • Thank for your reply.

    The reason I would like to have 'host computer' and 'target computer' is the storage on 'target computer' is too small to have VC installed.

    I am new for driver programming. 

    Is it possible to build/compile driver by using any tool in Windows Kit ?

    If the answer is not, I would like to have 'host computer' and 'target computer'.

    Please advise.

    Thursday, September 27, 2018 3:11 AM
  • Then look into the network option for debugging.   The other possibility is to find a serial port PCI card that exposes a legacy port.


    Don Burn Windows Driver Consulting Website: http://www.windrvr.com

    • Marked as answer by Doron Holan [MSFT] Thursday, September 27, 2018 1:54 PM
    • Unmarked as answer by ToniePCP Friday, September 28, 2018 3:55 AM
    Thursday, September 27, 2018 12:03 PM
  • Hi,

    The reason why you need a host computer and target computer is because you always want separate host and target computers. See here for a better explanation. Sometimes, the target can be a virtual machine - then the host needs even more memory and storage.

    Instead of Visual Studio you may try "Enterprise WDK".

    Happy learning.

    -- pa


    • Edited by Pavel A Thursday, September 27, 2018 6:03 PM
    Thursday, September 27, 2018 6:00 PM
  • Thank for all your kindly reponses.

    Let me explain why I want to use serial port.

    1. my target computer is atom Z8350 with 28.5GB SSD. Now it only has 12.7GB of free space.

    2. NIC and USB are un-passed by Windows Kit tools. That is, NIC and USB cannot be debugging ports.

    3. My target computer is a mini-PC, it cannot use 'extra PCIE card' for any purpose. The only port I can use are USB and Ethernet.

    4. I am new for driver programming.  Now I am using VS 2017. I think it is more easier to us VS directly. I will try to study Enterprise WDK. 

    Your advice are welcome.


    Friday, September 28, 2018 3:05 AM