locked
ServerValidator: PHP 5.2.16, Wincache 1.1 for PHP 5.2, SQL driver for PHP 2 and ASP.NET MVC 3 Beta not installed RRS feed

  • Question

  • User646347869 posted

    Hi there

    Running ServerValidator on my server it reports 

    "... 

    Product ASP.NET MVC 3 Beta is not installed.

    ...

    Product PHP 5.2.14 is not installed. 

    Product Windows Cache Extension 1.1 for PHP 5.2 is not installed.

    Product Microsoft Driver for PHP for SQL Server 2.0 in IIS is not installed.

    ..."

    but I have installed PHP 5.2.16 (using the Windows installer), Wincache 1.1 for PHP 5.2 and SQL Driver for PHP 2.0 and I can see them running a phpinfo.php page.

    I have also installed ASP.NET MVC 3 and I can see it in Control Panel as MVC 2.0 and MVC 1.0.

    How can I have all this products reported by ServerValidator?

    Are this blocking error to support WebMatrix ?

    Regards

    Giorgio

    Sunday, December 19, 2010 11:38 AM

Answers

  • User-359244760 posted

    At the same time, please note that MVC 3 is not required as a Spotlight requirement and that it is all right if ServerValidator cannot recognize some of the components (especially if you chose not to use Web Platform Installer to install them).

    If you believe all of the [Required] components are installed and configured correctly, regardless of the ServerValidator report, you can go ahead and provision a test account in the form of a Profile XML file and provide it to whg at microsoft.com. Thanks!

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, December 19, 2010 6:08 PM

All replies

  • User-2123722886 posted
    Did you install these through WebPI? ASP.NET MVC 3 Beta 3 Windows Cache Extension 1.1 for PHP 5.2 is not installed. Microsoft Driver for PHP for SQL Server 2.0 in IIS is not installed. ~Bilal
    Sunday, December 19, 2010 4:56 PM
  • User-2123722886 posted

    Can you please copy the below into ServerValidatorCommandLine.exe.config and drop it in the place where you have installed ServerValidator? It should generate a log in C:\svlog.log, which you can send to me at baslam at microsoft dot com. Thanks!

    <configuration>
     <system.diagnostics>
      <sources>
       <source name="DownloadManager"
        switchName="mySwitch"
        switchType="System.Diagnostics.SourceSwitch">
        <listeners>
         <add name="verboseListener"
          type="System.Diagnostics.TextWriterTraceListener"
          initializeData="C:\svlog.log">
         <filter type="System.Diagnostics.EventTypeFilter"
           initializeData="Verbose"/>
         </add>
         <remove name="Default"/>
        </listeners>
       </source>
      </sources>
     </system.diagnostics>
    </configuration>

    Sunday, December 19, 2010 5:14 PM
  • User-359244760 posted

    At the same time, please note that MVC 3 is not required as a Spotlight requirement and that it is all right if ServerValidator cannot recognize some of the components (especially if you chose not to use Web Platform Installer to install them).

    If you believe all of the [Required] components are installed and configured correctly, regardless of the ServerValidator report, you can go ahead and provision a test account in the form of a Profile XML file and provide it to whg at microsoft.com. Thanks!

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Sunday, December 19, 2010 6:08 PM
  • User646347869 posted

    I tried to install MVC 3.0 both from WebPI 3 and manually with the same result: product installed but not seen by ServerValidator.

    I installed the other product manually using the manual procedure explained in the page: http://learn.iis.net/page.aspx/951/install-server-components/.

    Monday, December 20, 2010 1:42 AM
  • User-2123722886 posted
    Giorgio, did you try the config file step I gave in an earlier post? Thank you so much for your help - it might help me track down what's going on. By the way, if you install MVC3 from WebPI and close and restart WebPI, does it show MVC3 as Installed or Not Installed? Thanks!
    Monday, December 20, 2010 1:44 AM
  • User646347869 posted

    Done!

    How can I send you the file?

    Monday, December 20, 2010 1:55 AM
  • User-2123722886 posted
    Please email it to me at: baslam at microsoft dot com. Of course replace at with @ and dot with . Thanks Giorgio! :)
    Monday, December 20, 2010 2:00 AM
  • User646347869 posted
    File sent
    Monday, December 20, 2010 10:52 AM
  • User-2123722886 posted
    Thanks Giorgio! Where on disk is your PHP installed? These checks will fail if PHP is not installed in the following two paths: C:\Program Files (x86)\PHP\v5.2 or C:\Program Files\PHP\v5.2: PHP 5.2.14 WinCache 1.1 for PHP 5.2 Microsoft Driver for PHP for SQL Server 2.0 That leaves us with the MVC3 not being detected as installed. I'm following up on that :)
    Monday, December 20, 2010 3:29 PM
  • User646347869 posted

    PHP is installed under c:\Program Files (x86)\PHP

    Note that the v5.2 sub directory is not used by the PHP installation process by default.

    Why are you using this directory to make the check?

    Regards

    Giorgio

    Tuesday, December 21, 2010 2:39 AM
  • User646347869 posted

    Moved PHP in to c:\Program Files (x86)\PHP\v5.2 and the extrensions in c:\Program Files (x86)\PHP\v5.2\ext.

    Copied php_pdo_sqlsrv_52_nts_vc6.dll, php_sqlsrv_52_nts_vc6.dll, php_wincache.dll in the extions directory and added these lines to the endo of php.ini:

    [PHP_WINCACHE]
    extension=php_wincache.dll
    [PHP_SQLSRV]
    extension=php_sqlsrv_52_nts_vc6.dll
    [PHP_PDO_SQLSRV]
    extension=php_pdo_sqlsrv_52_nts_vc6.dll

    Running phpinfo.php I can see all these extensions enabled and configured while ServerValidator sees WinCache but is still not able to see the SQL Driver for PHP v2.

    Giorgio

    Tuesday, December 21, 2010 3:14 AM
  • User-359244760 posted

    A new version of ServerValidator is available - would you like to try it out to see if it can detect your PHP installation better?

    http://go.microsoft.com/fwlink/?LinkId=207733

    Wednesday, January 5, 2011 6:10 PM
  • User646347869 posted

    Thanks Simon

     I'll try it as soon as possible

     Giorgio

    Tuesday, January 11, 2011 1:54 AM