none
Unable to Join Second ADFS 3.0 WAP server to Windows NLB RRS feed

  • Question

  • Does anyone have any experience with using Windows Load Balancer with ADFS, specifically with WAP? I was able to configure and add the ADFS server's to a WNLB, but not having any success with the WAP servers.

    The WAP servers are in a workgroup, and I successfully installed the proxy service and both servers. Both servers show up in the Remote Access Management Console (RAMC), which shows Operations Status as Green and working. On Server A, within the RAMC, I see both servers within the Cluster Servers. From Server A in the RAMC when I select it I have no issue seeing the configuration, but when I select on Server B I am repeatedly prompted for credentials. I can ping the server but I am not able to connect via File Explorer, \\ServerB\C$ and keep getting prompted for Credentials.

    Steps taken so far:

    1. Network Discovery was disabled and stayed disabled until starting services; Function Discovery Resource Publication, SSDP Discovery and UPnP Device Host.
    2. Tried connecting to the share using ServerB\Acct, WorkgroupName\Acct and just Acct, and keep getting prompted. 
    3. Created a new Account and added it to the Local Admin Group, which keeps failing as well. 
    4. Tried connecting to \\ServerB\C$ from a Domain Joined Machine using ServerB\Acct, WorkgroupName\Acct and keep getting prompted for Creds.
    5. Created a share on Server B and was able to access the share from both Domain joined machine and Server A.  

    Any ideas?


    Florian Baker

    Thursday, June 8, 2017 11:06 PM

All replies

  • Connecting to the Admin shares is generally a bad practice.

    But, for workgroup joined machines, I expect that you should always be prompted for credentials.  Since all authentication is local.  The token on each machine is unique.

    And, are you being prompted for authentication by the share or the file system?  they both need an auth.

    Now, you can always set up a proper share in a way that it will work.  and you are most likely not sharing the root of a drive (which by default only admins can access).


    Brian Ehlert
    http://ITProctology.blogspot.com
    Learn. Apply. Repeat.

    Friday, June 9, 2017 4:14 PM
    Moderator