none
Automatic Updates does not seem to be working RRS feed

  • Question

  • Hi Folks,

    I have written an Excel Addin which end users can download from my website (www.xlstatistician.com). I recently made some changes to the addin. When I publish the addin I set Updates to 'Check every time the customization runs'. However the updates do not appear when Excel is run. 

    Am I misunderstanding something?

    Other relevant information is that I deploy the addin using FTP to my website. The addin is written in vb.net (VS2010).

    Thanks,

    Bernie


    Bernie

    Saturday, July 14, 2012 5:51 AM

Answers

  • Hi Bernie,

    Thanks for posting in the MSDN Forum.

    Would you please show the "Customization Updates" Dialog's screen shooting for me? You will find it from "Proerties->Publish->Updates...".

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Bernie Ok Wednesday, July 18, 2012 11:01 AM
    Monday, July 16, 2012 6:38 AM
    Moderator
  • After you deploy the updated version, you should expect an VSTO update dialog while launching the Addin. Do you see that?

    When you say you don't the the update appear whe Excel run, does the old version launch? You'd better fill version number to Product Name, in the Publish options, this way you could see which version loaded.

    Btw, ClickOnce cache could be another reason, you may clear Click Once cache and relaunch the update. That may help:  mage.exe -cc

    Thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Marked as answer by Bernie Ok Wednesday, July 18, 2012 11:01 AM
    Wednesday, July 18, 2012 9:03 AM
    Moderator

All replies

  • Hi Bernie,

    Thanks for posting in the MSDN Forum.

    Would you please show the "Customization Updates" Dialog's screen shooting for me? You will find it from "Proerties->Publish->Updates...".

    Have a good day,

    Tom


    Tom Xu [MSFT]
    MSDN Community Support | Feedback to us

    • Marked as answer by Bernie Ok Wednesday, July 18, 2012 11:01 AM
    Monday, July 16, 2012 6:38 AM
    Moderator
  • Thanks for the reply Tom,

    Best

    Bernie


    Bernie


    • Edited by Bernie Ok Monday, July 16, 2012 6:53 AM
    Monday, July 16, 2012 6:48 AM
  • After you deploy the updated version, you should expect an VSTO update dialog while launching the Addin. Do you see that?

    When you say you don't the the update appear whe Excel run, does the old version launch? You'd better fill version number to Product Name, in the Publish options, this way you could see which version loaded.

    Btw, ClickOnce cache could be another reason, you may clear Click Once cache and relaunch the update. That may help:  mage.exe -cc

    Thanks.


    Forrest Guo | MSDN Community Support | Feedback to manager

    • Marked as answer by Bernie Ok Wednesday, July 18, 2012 11:01 AM
    Wednesday, July 18, 2012 9:03 AM
    Moderator
  • Thank you Forrest,

    I am not clear on what exactly what you mean by 'launching the Addin'. I don't know exactly what the update dialog is. I presume it is something that the end user would see and allow the update to proceed. If this is the case then I have never seen the update dialog.  Let me explain the process I go thru.

    (1) I publish my addin to the development PC.

    (2) Using FTP I copy the entire contents of the publish folder to my website.

    (3) End users have no problem installing this addin on their PC from the website. The problem is that they do not receive future updates automatically.

    I do not use version numbers but I am certain that clients are not getting updates because the latest updates makes clearly visible changes to the Excel ribbon. I suspect that I am deploying the addin incorrectly but I do not know what the problem may be.

    Regards,

    Bernie


    Bernie

    Wednesday, July 18, 2012 10:15 AM
  • Tom and Forrest,

    I wish to apologize for wasting your time. I was uploading an older publish folder to my website.

    Regards,

    Bernie


    Bernie

    Wednesday, July 18, 2012 11:01 AM