none
Unable to Delete Blob Storage Account Using Mac

    Question

  • From Joshua Garcia @CaptainJAG31 via Twitter.

    "Hey I can't delete some Blob storage, and it's costing me money. How do I fix this???"

    @AzureSupport provided the following documentation: aka.ms/d1269914

    "Yeah, I've done that, and it didn't help. Looked at scripts, but I shouldn't have to run command line to delete stuff. the main issue is a Lease lock, which is why I have looked at scripts. I discontinued my @bitnami VM from their dashboard"

    "I found the scripts, never ran them, zip file and all. I am on Mac, is that the fix? I can make a Windows VM, but if that...is the answer, then maybe a Mac script should be put out. This issue has been around for awhile, I just pay it tho"

    "it actually was not, I run the scripts and get a 'can't find storage account'...'it doesnt exist'. Yet I see it in my portal"

    Current Synopsis from Customer: "Yeah I tried using that 'break a locked lease' script that you sent me, after installing the tools and everything. I get a 'can't find account because it doesn't exist....please make sure that it spelled correctly'. I tried the leased and deleted blob URL that you gave me and I either get a timeout or it says there is an XML error. This specific blob was launched through Bitnami and I'm not sure if that has something to do with it or not. During my attempts to delete the blob I removed the Virtual Machine I had in the bitnami portal and disassociated my account from Azure. Maybe that had something to do with it? My portal says the lease time is infinite as well, and that blog is the only thing in that storage account. "

    Thanks,

    @AzureSupport

    Wednesday, July 27, 2016 2:13 AM

All replies