locked
Metro IE 10 and default browser

    Question

  • Hello,

    I have a question. If the metro IE 10 is open, does it act as the default browser? I recently had a word document with hyperlinks embedded in the text. I did a ctrl+click to open them. I currently have Google Chrome (no offense to IE, I am just use to it) as my default browser. I clicked the links expecting a tab to appear on Chrome, but nothing happened. I tried several more times until I decided to copy and paste the address directly into Chrome. I later realized the links had opened in a suspended metro IE 10 session. I just wanted to know if metro IE takes precedent over desktop browsers? 

    Sunday, October 09, 2011 7:19 PM

Answers

  • Hi biomenace,

    Could you try navigating to Control Panel > Programs > Default Programs to set Chrome as your default browser? File associations and default programs have been changed in Windows 8 to put more control in the hands of users.  As such, applications are no longer able to set themselves as the default handler directly.  


    Sunday, October 09, 2011 9:43 PM

All replies

  • Hi biomenace,

    When you said you had Google Chrome as your default browser, did you set it through the google chrome prompt that asks if you want it as your default browser or did you actually go into control panel to set your default programs?

    Sunday, October 09, 2011 7:49 PM
  • Just through Chrome's prompt.
    Sunday, October 09, 2011 8:50 PM
  • Hi biomenace,

    Could you try navigating to Control Panel > Programs > Default Programs to set Chrome as your default browser? File associations and default programs have been changed in Windows 8 to put more control in the hands of users.  As such, applications are no longer able to set themselves as the default handler directly.  


    Sunday, October 09, 2011 9:43 PM
  • Well that did succeed in allowing me to open the hyperlinks with Chrome. However, when I set chrome as the default program, the Metro IE 10 tile gets replaced with a tile representing the desktop IE 10. Clicking said tile opens the desktop IE 10. I can no longer use metro IE 10. Resetting Internet explore as the default browser brings back the metro IE 10 tile. 
    Monday, October 10, 2011 1:05 AM
  • Hi biomenace,

    Yes that is true.  Once you set Chrome as your default browser, because there isn't an equivalent Metro version of Chrome, clicking the tile just defaults back to the desktop IE.

    Monday, October 10, 2011 1:31 AM
  • Is that an issue that will be fixed? It would be nice to have the metro IE for to look at facebook quickly, or surf wikipedia without opening the desktop. 
    Monday, October 10, 2011 8:13 PM
  • The user experience should be a lot better if and when Chrome comes out with a Metro equivalent version.  As for whether the default will be changed to metro IE when no metro browsers are found, I am sorry to say that I cannot let you know for sure. What I can tell you though is that this is a scenario that we are aware of and will continue to consider feedback received from users. 

    Meanwhile, why don't you give setting IE back to your default browser a try :p. That way you won't have to switch back to classic desktop whenever you click on a link.


    Monday, October 10, 2011 8:51 PM
  • Hi biomenace,

    Could you try navigating to Control Panel > Programs > Default Programs to set Chrome as your default browser? File associations and default programs have been changed in Windows 8 to put more control in the hands of users.  As such, applications are no longer able to set themselves as the default handler directly.  


    Hi HaoWei,

    Thanks for the answer, but I am wondering why default browser when try to open url on file explorer is "Metro IE" not "Desktop IE"?

    I have to change "Default Programs" setting to change it by default, or it might confuse if we want to execute shell comment to open browser on desktop mode, but it might open on "Metro mode".

    So far, as I know it could call correctly if we using correct command handle on [HKEY_CLASSES_ROOT\http\shell\open\command]

     


    • Edited by Evan Lin Wednesday, November 09, 2011 9:00 AM
    Wednesday, November 09, 2011 8:52 AM