none
Internet Connection Problems Interrupting Visual Studio Installation

    Question

  • I need to find a way to download Android SDKs for Visual Studio 2015 because my connection problems keep interrupting the download when I try to get them from the installation. I also have the log file, but I don't know how to attach it here and it's also too long to copy-paste in here.
    Thursday, November 24, 2016 9:14 AM

Answers

  • Hi DragonOsman2,

    Thank you for posting in MSDN forum.

    >> but I don't know how to attach it here

    About uploading the log file, please use  https://onedrive.live.com/ and share the link here.

    Just according to your description, the root cause is pending on the network connection, if it is interrupted from time to time, it leads to that some packages are missing or broken during the download process, and the result is failing to installing the Android SDKs.

    You have better consult with your Network operator, to fix the .network problem.

    Then go to Control Panel >Programs >Programs and Features, select Microsoft Visual Studio 2015 and click on ‘Repair’ and 'Modify'. check and install the Android related components.

    If it's difficult to fixing this, I suggest you could find another machine with good Internet connection, then create an offline installer of the Android related SDKS.

    Download a web installer from Visual Studio Emulator for Android, and use /layout command to download full files.

    You could take a look at my reply about the detailed steps in the following thread:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/42a77129-c0f6-4113-9277-a2b0acbec641/emulator-for-visual-studio-community-2015?forum=vssetup

    If there is any problem existed, please feel free to let me know, I'm willing to help you solve this.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 25, 2016 7:27 AM
    Moderator

All replies

  • Hi DragonOsman2,

    Thank you for posting in MSDN forum.

    >> but I don't know how to attach it here

    About uploading the log file, please use  https://onedrive.live.com/ and share the link here.

    Just according to your description, the root cause is pending on the network connection, if it is interrupted from time to time, it leads to that some packages are missing or broken during the download process, and the result is failing to installing the Android SDKs.

    You have better consult with your Network operator, to fix the .network problem.

    Then go to Control Panel >Programs >Programs and Features, select Microsoft Visual Studio 2015 and click on ‘Repair’ and 'Modify'. check and install the Android related components.

    If it's difficult to fixing this, I suggest you could find another machine with good Internet connection, then create an offline installer of the Android related SDKS.

    Download a web installer from Visual Studio Emulator for Android, and use /layout command to download full files.

    You could take a look at my reply about the detailed steps in the following thread:

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/42a77129-c0f6-4113-9277-a2b0acbec641/emulator-for-visual-studio-community-2015?forum=vssetup

    If there is any problem existed, please feel free to let me know, I'm willing to help you solve this.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 25, 2016 7:27 AM
    Moderator
  • I was able to get the main problem fixed for that by doing a Repair from Visual Studio's UI itself, but I still have this one problem where I get popup window that mentions an "Exception" that had occurred. 

    Should I make another thread for that and mark this one as solved?

    Friday, November 25, 2016 10:04 PM
  • Hi Dragon,

    Thank you for sharing use your solution and result here.

    You are to the point , one thread one question, if you have solve this successfully, and if you think my reply is helpful, please mark my reply and your reply as the answer.

    At the same time, you could post a new question in our forum for dedicated support.

    We are willing to help you solve this.

    Have a nice day:)

    Best Regards,

     

     

     


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 28, 2016 9:48 AM
    Moderator