none
Clicking the Save Button in Internet Explorer 11 RRS feed

  • Question

  • Hello everyone,

    I am working on a VBA script to automatically generate and download business reports from our intranet browser application. (SAP Webi)
    To do so, the script, using the Microsoft Internet Controls Library, logs in, clicks a few buttons until it reaches the "Generate Report Button."
    When the server has generated the report (which takes a few seconds to a few minutes dependent on the size of the report) the Internet Explorer Save As button appears, just like
    here. (http://i.stack.imgur.com/NofcV.jpg) After that, I am stuck. I have seen solutions like the UrltoFileA function, but that only works if no log in is necessary.
    Also, I have Internet Explorer run in invisible mode to prevent the user to tinker with the browser while the script is running. A solution that keeps the browser hidden is most preferable.
    Can someone point me in the right direction how to solve this problem?
    Thanks in advance.
    With Regards,
    Casimir M

    Thursday, February 9, 2017 7:28 PM

Answers

All replies

  • I use AutoIT to do this.  I don't have the browser hidden.  I assume it needs to be visible.
    • Marked as answer by Casimir M Sunday, February 12, 2017 7:18 PM
    Friday, February 10, 2017 3:31 AM
  • Thank you for your reply, unfortunately, I am not allowed to install AutoIt on the corporate computers. I found a workaround though, Webi has a function to show the report on screen, so I was able to grab the HTML file and rebuild the table in Excel. So problem solved.
    With regards,
    Casimir M

    Sunday, February 12, 2017 7:18 PM