none
Mailbox DB corruption RRS feed

  • Question

  • Hello,

    Due to disk corruption we recently got our mailbox db crash, i tried with eseutil /p switch , it went all the way and in middle it just quit without any reason. Now when i'm trying to perform the same it shows invalid Database or corrupted database.

    I tried with various tools like , Kernal Exchange Recovery, Stellar, Enstella Exchange recovery. all shows no data. The EDB file is of 50Gb size.

    Can anyone help me with these. ?


    Abdul Razak

    Wednesday, February 5, 2014 6:58 AM

All replies

  • As you have mentioned that you tried Eseutil/p and many other  tools, but Eseutil command is used against hard repair scenario if exchange server database corrupt. This command goes through the database and check to repair critical structures inside the database(like, system tables, attachment tables, and so on) and check for damaged pages in the databases. However, you can have check this software (http://www.lepide.com/exchange-manager/) which proficiently repair corrupt exchange database and restore the important data successfully. I hope, it could be an appropriate solution for you.


    Wednesday, February 5, 2014 8:12 AM
  • If Eseutil /p has failed, then you should try restoring exchange database from backup and replay log files to recover maximum emails.

    Regards,


    SK

    Wednesday, February 5, 2014 9:10 PM
  • Hi Abdul,

    It seems the database is corrupted beyond its state and cannot be repaired even with eseutil /p, eseutil /d.

    In most of the disk corruption cases we just need to restore it from the backup because the DB will go beyond the corrupted state and thats where that DB becomes unmountable

    So taking psts of the user accounts and then mounting with a blank store would be better option instead of hard repair and trying with third party tools etc.,

    rebuild the DB or restore it from backup

    Please mark as helpful if you find my contribution useful or as an answer if it does answer your question.That will encourage me - and others - to take time out to help you.

    Regards,
    Sathish

    Wednesday, February 5, 2014 9:42 PM
  • Hi Abdul,

    What is the problem with the backup?

    Have you tried to restore the database from updated backup?


    Thursday, February 6, 2014 6:36 AM