locked
Error APPX0703: Manifest references file 'XXX.dll' which is not part of the payload

    General discussion

  • Hi! I have one big problem which I have not figured out how to solve. I looked up Internet, but could not find any clues. I created a game with DirectX11.1 for the first time. (As for how to make it, Because this is my first DirectX game, I used "Direct3D Application" template to create a game, which means that it is coded by C++ and no xaml. In order to submit this game to windows store, I need to create "GDF" dll (which contains ESRB rating) and specify it as a property of "Game Definition Container" in "Package manifest" page in "Visual Studio Express 2012 for windows8". I used GDFMaker (C:\Program Files (x86)\Windows Kits\8.0\bin\x86). I created a dll on "visual studio 2012 for windows8) and copied it under my source project directory. When building this solution, I get a error message as follows.

    "Error APPX0703: Manifest references file 'XXX.dll' which is not part of the payload"

    I did exactly same thing for previous games, but these were sucessful. (These games are based on Javascript + HTML5)

    For the case of "Javascript + HTML5", it has "Any CPU" platform when building an application. So to release a game, It is built on this platform.

    As for "DirectX11.1", it has 3 CPU options, such as "ARM, win32, X64". I tried all platforms, but all failed to build.

    I knew the meaning of error message. It says "Package manifest" can not find a path for XXX.dll(GDF file). When specifying a CPU option, it outputs a executable file under some designated folder. That folder does not contain XXX.dll, which I think, cause this problem.

    I also tried to copy XXX.dll to all output folders beforehand, but it did not work.

    My alternative solution right now is as follows.

    At solution explorerer, I right-click on "XXX.dll" and open "Proerty" page. At "Compisition property", it has "item type". It is set as "not included in Build" as a default, but I change it as "XML". I don't know why, but this builds the app without any errors. But I don't think this is right solution, as looking into output directories it does not contain any "XXX.dll".  I am not familiar with Visual studio, so If you know this solution, please explain to me step by step, considering that I am a beginner. Thank you.

    • Changed type emi5050 Saturday, July 13, 2013 5:46 AM
    Saturday, June 29, 2013 2:50 AM

All replies