none
IIS7 classic asp and Session Problem RRS feed

  • Question

  • I am getting Following error in my application which is running on Windows Server 2008, IIS7 and SS2008
    ______ERROR______
    error '8002801c'

    /LM/W3SVC/1/ROOT/FLEETSERVICES/global.asa, line 38
    ______Which corresponds to below code_______
    Sub Session_OnStart
    Response.Redirect("/Fleetservices/default.asp?URL=" & Request.Cookies("InfoSys")("URL"))
    dim dtLastMonth
    dtLastMonth = DateAdd("m", -1, now)
    Session("WorkingDate") = DateSerial(Year(dtLastMonth), Month(dtLastMonth), 1)
    End Sub

    ____I tried____
    http://blogs.iis.net/lprete/archive/2009/01/04/session-onend-classic-asp-and-iis-7-0.aspx
    appcmd set config /section:system.webServer/asp /runOnEndAnonymously:false
    but still the error is coming.

    __WHAT NOW__

    • Changed type YiChun Chen Thursday, July 9, 2009 6:47 AM
    Tuesday, July 7, 2009 9:28 AM

Answers

  • Hi Abhisharma,

    This forum is for the support of Visual Studio installation. Since your issue is related to IIS, you could post your thread on IIS forum. This will make answer searching in the forum easier and be beneficial to other community members as well.

    Thank you for your understanding.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by YiChun Chen Tuesday, July 14, 2009 8:37 AM
    Thursday, July 9, 2009 6:48 AM