locked
The request URI is invalid. RRS feed

  • Question

  • I mapped my domain name on GoDaddy to my static website on Azure and this is the feedback I got. 

    The request URI is invalid.

    • HttpStatusCode: 400
    • ErrorCode: InvalidUri
    • RequestId : 5f4500db-f01e-00ee-671f-930e73000000
    • TimeStamp : 2019-11-04T14:51:47.3723394Z

    How do I resolve this?

    • Edited by ENkansah Monday, November 4, 2019 2:54 PM
    Monday, November 4, 2019 2:52 PM

All replies

  • Hello ENKansah, 


    Thank you for reaching out to us.

    Have you validated your domain by adding asverify as a CNAME in your registrar. 

    Configure a custom domain for accessing blob or website data in your Azure storage account, like www.contoso.com. There are two methods you can use to set up a custom domain.

    • Create a CNAME record with your DNS provider that points from your domain (like www.contoso.com) to name.blob.core.windows.net or name.z21.web.core.windows.net then enter you domain below. This method is simpler, but results in a brief downtime while Azure verifies the domain registration. (The bold one will be your static webpage URL)
    • Create a CNAME record with your DNS provider that points from the "asverify" subdomain (like asverify.www.contoso.com) to asverify.name.blob.core.windows.net or asverify.name.z21.web.core.windows.net. After this step completes, enter your domain below (exclude the 'asverify' subdomain). This method does not incur any downtime. To use this method, select the 'Use indirect CNAME validation' checkbox

     1st option would be preferred where you need to point your custom domain to the static web page directly. 

    Also you can take a look at the below Docs doc for more reference.

    1. Configure Custom Domain

    2. Map your Custom Domain

    I hope this information helps. Try this and let us know if it resolves your issue. 

    Thank you msrini-MSFT for addressing this issue on MSDN thread. Resurfacing the answer here for Community members. 


    Monday, November 4, 2019 6:07 PM
  • Hello Monika,

    It worked. Thank you. 

    Tuesday, November 5, 2019 9:03 AM
  • Hello ENkanash,

    I’m glad to hear that the issue is resolved for you.

    Please feel free to “Mark as Answer” and “Upvote” for the same so it would be beneficial for the other community members..

    Tuesday, November 5, 2019 11:09 AM