locked
Could not load file or assembly ? RRS feed

  • Question

  • Hi every body,

    I wrote a programme in my pc, and programme is running in my PC perfectly, and then i have created a setup project using Setup wizard , after creating a setup project i already installed my programme to a different computer in the network, and programme successfully installed to the target machine, but problem is when i run thr programme  i am getting this ERROR ?


    "System.IO.FileLoadException: Could not load file or assembly 'Test.MyStorage, Version=1.0.847.22469, Culture=neutral, PublicKeyToken=8840063030bd4bce' or one of its dependencies. The located assembly's manifest definition does not match the assembly reference. (Exception from HRESULT: 0x80131040)
    File name: 'Test.MyStorage, Version=1.0.847.22469, Culture=neutral, PublicKeyToken=8840063030bd4bce'
       at StrReader.MsgReader..Path(String FilePathString)"



    What can i do for this matter ?

    i know if i run     sn -k "targetdllname.dll"   from the visual studio command prompt this  problem will solve ,

    But the problem is in my target computer there is no visual studio command prompt ? cos i haven't installed .Net in that target machine, but i already installed the .Net framework in that machine


    any idea to sort out this problem ?

    regards
    suis
    Tuesday, October 23, 2007 8:18 AM

Answers