none
IDOC Syntax Error on SAP RRS feed

  • Question

  • Hi,

    I'm having some issues with an integration between SAP and BizTalk.

    I take an XML file and map it to a strongly typed IDOC schema (PORDCR101) that I generated using the WCF consume adapter function of the mySAP 3.0 Business Suite. The orchestration works successfully and sends the IDOC to SAP no problems but when I check the status of the IDOC on SAP I keep getting an IDOC syntax error saying that no hierarchy could be determined.

    this is the error i get.

    EDI: Syntax error in IDoc (segment cannot be identified)

    Message no. E0078



    Is there some setting that needs to be enabled somewhere?

    Thanks in advance.
    Monday, December 1, 2008 6:31 PM

All replies

  • Are the SEGNAM, SEGNUM and PSGNUM fields in the DataHeaderRecord getting populated correctly? (and maybe also the HLEVEL)

    Wednesday, December 3, 2008 8:01 AM
  • Hello,

    Could you please let me know how you have solved this issue. We are getting same error now when we send IDOC to SAP in BizTalk 2013 using nco connection type using wcf-sap adapter

    Monday, July 18, 2016 9:07 AM