locked
windows store in app purchase experience RRS feed

  • Question

  • Hello,

    My app is published in the store today. My app is free but I have a in-app purchase feature. Today I downloaded my app from the store and tried clicking on button for in-app purchase. I was expecting a store dialog box with in-app feature details with an option to buy feature, but I am getting simulator dialog box instead. the user id and machine where I installed the app were used before for testing. I am not sure what other peoples are seeing when they click on this button. is there a delay when the in-app features are available on the license server?

    I was using CurrentAppSimulator class for my testing. I then changed the code to use CurrentApp before building a package for certification. Any idea what might be going wrong? why is the app displaying license simulator dialog box instead of standard Microsoft dialog box for in-app purchase?

    Thursday, November 29, 2012 3:54 AM

Answers

All replies

  • Hi Kiraningale,

    This sounds like it is still pulling licensing information from the simulator. Please have a look at the page on supporting in-app purchases and if you still have questions after that, let us know. http://msdn.microsoft.com/en-us/library/windows/apps/hh694067.aspx

    Thanks,

    Jesse

    • Marked as answer by kiraningale Friday, December 7, 2012 8:30 PM
    Thursday, November 29, 2012 8:08 PM
  • There was a coding issue. I was still calling the simulator when user tried to buy in-app purchase. I don't know how it passed certification in the first place. May be they don't check in-app purchases.

    I fixed the problem with a new build. Thanks!

    Friday, December 7, 2012 8:29 PM
  • Someone should tell the testers to check this - I can't imagine anyone would want their app to ship with the simulator enabled, nor Microsoft to want it in the store.
    Sunday, December 9, 2012 1:55 AM