Xamarin Failing to Install RRS feed

  • Question

  • User2714 posted

    I just joined the Xamarin community, and I'm looking for solutions to my installation woes. Any help would be greatly appreciated.

    I'm running a Macbook Air on OS X 10.8.2. I get an error report right after accepting the Xamarin license (i.e. after the first step). I've attached a screenshot showing the dearth of stack traces related to the error; however, I've also included the installation log, which indicates that a Null Reference error was thrown when the installer was performing an action related to, possibly, the searching of my Android SDK. I have my Android SDKS (7, 8, 10, 12, 14, 17) installed in /Library/Frameworks/Android.

    Thanks in advance,

    [2013-02-21 01:27:51.620] [Info] Installation ID: 0b0071c1-32d9-4d1f-ba7c-a5a84b481de1 [2013-02-21 01:27:51.627] [Info] Operating system: Mac OS X v10.8.2 (10.8.2; Mac OS X 10.8.2 (10.8.2 build version: 12C60)), 32-bit [2013-02-21 01:27:51.627] [Info] Installer product: Xamarin [2013-02-21 01:27:51.628] [Info] Installer version: [2013-02-21 01:27:51.628] [Info] Status: in progress [2013-02-21 01:27:59.088] [Debug] Waiting for manifests to finish downloading. [2013-02-21 01:27:59.088] [Debug] Initial task executing (WaitingForActivation). Waiting for it to finish. [2013-02-21 01:27:59.793] [Info] Retrieving installation manifest. [2013-02-21 01:27:59.794] [Info] Downloading from 'http://xamarin.com/installerassets/v3/Mac/Universal//InstallationManifest.xml'. [2013-02-21 01:27:59.795] [Debug] Setting download timeout for 'http://xamarin.com/installerassets/v3/Mac/Universal//InstallationManifest.xml' to 60s [2013-02-21 01:27:59.897] [Info] Retrieving installation size manifest. [2013-02-21 01:27:59.897] [Info] Downloading from 'http://xamarin.com/installerassets/v3/Mac/Universal//InstallationSizes.xml'. [2013-02-21 01:27:59.897] [Debug] Setting download timeout for 'http://xamarin.com/installerassets/v3/Mac/Universal//InstallationSizes.xml' to 60s [2013-02-21 01:27:59.998] [Info] Installation size manifest not found online, using the bundled copy [2013-02-21 01:27:59.999] [Info] Installation size manifest: reading from assembly. [2013-02-21 01:28:00.101] [Info] Determining list of software items to install. [2013-02-21 01:28:00.101] [Debug] Processing update nodes from the manifest. [2013-02-21 01:28:00.101] [Debug] Creating and initializing software item 'Mono Framework' [2013-02-21 01:28:00.605] [Debug] Creating and initializing software item 'Java SDK' [2013-02-21 01:28:00.605] [Debug] Creating and initializing software item 'Android SDK' [2013-02-21 01:28:00.607] [Debug] Creating and initializing software item 'Xamarin Studio' [2013-02-21 01:28:00.607] [Debug] Creating and initializing software item 'Xamarin.Android' [2013-02-21 01:28:00.607] [Debug] Creating and initializing software item 'Xamarin.iOS' [2013-02-21 01:28:00.607] [Debug] Detecting software item 'Mono Framework' [2013-02-21 01:28:00.607] [Info] Checking whether Mono needs update/installation [2013-02-21 01:28:00.709] [Info] Mono runtime found in /Library/Frameworks/Mono.framework/Versions/2.10.11 [2013-02-21 01:28:00.709] [Info] Mono version 2.10.11 was found in /Library/Frameworks/Mono.framework/Versions [2013-02-21 01:28:00.810] [Info] Status: successful [2013-02-21 01:28:00.810] [Info] Component 'Mono Framework' v. 2.10.11 present [2013-02-21 01:28:00.812] [Info] Software item 'Mono Framework': up to date [2013-02-21 01:28:00.812] [Debug] Detecting software item 'Java SDK' [2013-02-21 01:28:00.812] [Info] Checking whether Mac JDK needs update/installation [2013-02-21 01:28:00.812] [Info] Status: successful [2013-02-21 01:28:00.812] [Info] Component 'Java SDK' v. 1.6.0 present [2013-02-21 01:28:00.813] [Info] Software item 'Java SDK': up to date [2013-02-21 01:28:00.813] [Debug] Detecting software item 'Android SDK' [2013-02-21 01:28:00.813] [Info] Checking if Android SDK needs to be updated/installed [2013-02-21 01:28:00.813] [Info] Fetching Android SDK manifest. [2013-02-21 01:28:00.813] [Info] Manifest URL: http://dl.google.com/android/repository/repository-7.xml [2013-02-21 01:28:00.813] [Info] Using default samples: [2013-02-21 01:28:00.830] [Info] Downloading from 'http://dl.google.com/android/repository/repository-7.xml'. [2013-02-21 01:28:00.831] [Debug] Setting download timeout for 'http://dl.google.com/android/repository/repository-7.xml' to 25s [2013-02-21 01:28:01.033] [Info] AVD 'MonoForAndroid API 14' needs to be created. [2013-02-21 01:28:01.033] [Info] AVD 'MonoForAndroid API 12' needs to be created. [2013-02-21 01:28:01.034] [Info] AVD 'MonoForAndroid API 10' needs to be created. [2013-02-21 01:28:01.034] [Info] AVD 'MonoForAndroid API 8' needs to be created. [2013-02-21 01:28:01.034] [Info] AVD 'MonoForAndroid API 7' needs to be created. [2013-02-21 01:28:01.034] [Info] Status: failed. [2013-02-21 01:28:01.034] [Exception] Failed to detect component 'Android SDK' [2013-02-21 01:28:01.034] [Exception] System.NullReferenceException: Object reference not set to an instance of an object [2013-02-21 01:28:01.034] [Exception] at Xamarin.Web.Installer.Installer.AndroidSoftwareItem.Detect () [0x00000] in :0 [2013-02-21 01:28:01.034] [Exception] at Xamarin.Web.Installer.Installer.AndroidSoftwareItem.NeedsUpdate () [0x00000] in :0 [2013-02-21 01:28:01.034] [Exception] at Xamarin.Web.Installer.TasksManager.ComponentDetector (ISoftwareItem si) [0x00000] in :0 [2013-02-21 01:28:01.034] [Error] No selected SDK, cannot enqueue downloads [2013-02-21 01:28:01.035] [Debug] Detecting software item 'Xamarin Studio' [2013-02-21 01:28:01.035] [Info] Checking whether Xamarin Studio needs installation/updating [2013-02-21 01:28:01.035] [Info] Status: successful [2013-02-21 01:28:01.035] [Info] Component 'Xamarin Studio' v. 4.0.0 present [2013-02-21 01:28:01.035] [Info] Software item 'Xamarin Studio': up to date [2013-02-21 01:28:01.035] [Debug] Detecting software item 'Xamarin.Android' [2013-02-21 01:28:01.035] [Info] Checking whether Xamarin.Android SDK needs installation/updating [2013-02-21 01:28:01.036] [Info] Xamarin.Android build files not found. [2013-02-21 01:28:01.036] [Info] Base Xamarin.Android directory not found. [2013-02-21 01:28:01.036] [Info] Xamarin.Android SDK 4.6.0 requires installation. [2013-02-21 01:28:01.137] [Info] Status: successful [2013-02-21 01:28:01.137] [Info] Software item 'Xamarin.Android': not up to date [2013-02-21 01:28:01.137] [Info] Component 'Xamarin.Android' v. 4.6.0 absent [2013-02-21 01:28:01.138] [Debug] Detecting software item 'Xamarin.iOS' [2013-02-21 01:28:01.138] [Info] Checking whether Xamarin.iOS needs update/installation [2013-02-21 01:28:01.138] [Info] MonoTouch base directory not found. [2013-02-21 01:28:01.138] [Info] Xamarin.iOS needs to be installed. [2013-02-21 01:28:01.138] [Info] Status: successful [2013-02-21 01:28:01.138] [Info] Software item 'Xamarin.iOS': not up to date [2013-02-21 01:28:01.138] [Info] Component 'Xamarin.iOS' v. 6.2.0 absent [2013-02-21 01:28:01.139] [Info] Detection complete [2013-02-21 01:28:01.139] [Info] Initial task completed successfully [2013-02-21 01:28:01.139] [Debug] Detection complete on the introduction page, determining the next step.

    Thursday, February 21, 2013 1:39 AM

All replies

  • User2714 posted

    I've attached the installation log as a text file because it is unreadable in its current format.

    Thursday, February 21, 2013 1:44 AM
  • User51 posted

    Hi Alexander,

    It's hard to tell what causes the null reference exception from the log, unfortunately. I have a suspicion, however, and I hope you don't mind trying something out. Please copy your Android SDK from /Library/Frameworks to ~/Library/Developer/Xamarin/android-sdk-mac_x86 and let's see if the installer works when you do that. Thanks for reporting, we'll fix the issue in one of the next updates to the installer.

    Thursday, February 21, 2013 9:21 AM
  • User2714 posted


    Thanks for responding -- I really appreciate it. Unfortunately, moving the Android SDK to the specified location did not work. After a few hours of fiddling around, I decided to explicitly set the Android SDK location in Xamarin Studio.

    Much to my surprise, I was unable to do so. Xamarin Studio threw an error regarding permissions: It was unable to open "/Users/USERDIRECTORY/.config". After a simple "sudo chmod 777 /Users/USERDIRECTORY/.config", I was able to set my Android SDK location and install Xamarin.

    I look forward to using Xamarin, and I hope this post helps anyone else with similar installation woes.

    Thursday, February 21, 2013 3:56 PM
  • User48 posted

    Do you happen to know what the original owner and permissions on ~/.config were? It seems rather odd that ~/.config wouldn't be writable by the current user...

    Thursday, February 21, 2013 4:05 PM
  • User2714 posted


    I apologize, but I failed to check what the original permissions were. I agree that it's certainly odd that something in my user directory wouldn't be writable by...well, me. I should note that before "chmod"-ing this directory, I tried "sudo open /Applications/Xamarin\ Studio.app", and Xamarin Studio still lacked the sufficient permissions to write to that file.

    Let me know if I can be of any other assistance.

    Thursday, February 21, 2013 4:12 PM
  • User51 posted

    It is possible the directory was owned by you but was chmod 644 or similar (without the 'exec' bits) which makes it writable as an inode entry but not browsable.

    Regarding Android SDK - the installer installs it running with permissions of regular user, so it won't be able to write to any of the locations outside the user home directory. Can you attach the installer log from the session after you moved Android SDK to the location I indicated?

    Thursday, February 21, 2013 5:20 PM
  • User2714 posted


    The only other folder in ~/.config is "Nokia" (Qt-related files). This makes me think that the issue stems from my old Qt Suite installation. The installer for Qt might have messed up my permissions.

    I've attached an archive of my installation logs from today. There's one installation log from 12:XY AM (EST) that recorded the installation prior to moving the Android SDK location as per your advice. Every other installation log should have a changed SDK location, AFAIK. FYI, I ended up moving the SDKs to "/Developer/SDKs/" as stated on an installation guide on the Xamarin website. I'll likely move it to ~/Library/Xamarin/ as you stated because, to my knowledge, /Developer/SDKs/ was eliminated in 10.8.X, and I'd rather conform to current Mac development standards.

    Thursday, February 21, 2013 5:37 PM
  • User51 posted


    The logs suggest that installation went OK, the only thing that's being reinstalled is the NDK. We are aware of that bug, however, it will be fixed in one of the next installer updates.

    Regarding the SDK locations. We chose ~/Library/Developer/Xamarin as the root for the SDK since that is one of the blessed locations for the SDKs - I suggest you move your Android SDK to that directory (or to ~/Library/Developer/SDKs, if you prefer, of course) since that keeps all the locations writable by you confined to your home directory and you're not exposing yourself to the risk of some Xcode (for instance) update deleting the contents of /Developer (I think it happened before)

    Thursday, February 21, 2013 5:45 PM
  • User17673 posted

    Hi, Just came across this thread as I encountered the exact problem after spending a couple hours trying to make Android Studio's included sdk show itself to the Xamarin installer. The key to fixing this was indeed related to ~/.config. In my case, I use macports and had installed htop. htop was the first accessor (and therefore creator) of ~/.config so since macports is run with sudo, the directory -- erroneously -- was owned by root. So to fix it, I ran from terminal ~chris $ chown -R chris ~/.config.
    As Jon mentioned, you should own all the files in ~. To be really safe though, you probably should be:

    ~ chris $ chown chris ~/.config # sans the -R.

    Also, if it's not obvious, replace chris with the user that owns ~ .

    Hope this helps someone else.


    Saturday, July 13, 2013 6:16 PM
  • User17719 posted

    if i have already installed android sdk ,xamarin studio ,vs12 then how to install Xamarin for android or any option to installing xamarin.android with out using xamarininstaller

    Sunday, July 14, 2013 4:27 PM