locked
Unable to launch the ASP.NET Development Server because port '80' is in use. RRS feed

  • Question

  • User-783820979 posted

    Subject says it all.

    Running Windows 7, VS 2010 Beta 2

    When I try to run my website at port 80 I get that error. It works fine on another port, like 81.

    If I run VS2010 NOT as admin I get a different error. 

    Failed to start ASP.NET Development Server on Port:80
    Error:An attempt was made to access a socket in a way forbidden by its access permissions

    Netstat shows that the system is using port 80.

    Proto  Local Address          Foreign Address        State           PID 

     TCP    127.0.0.1:80           IANSUL1:0              LISTENING       4

    > ps -id 4
    Handles  NPM(K)    PM(K)      WS(K) VM(M)   CPU(s)     Id ProcessName
    -------  ------    -----      ----- -----   ------     -- -----------
        645       0      108        180     3               4 System

    TIA

    -Ian

    Wednesday, December 30, 2009 9:12 PM

Answers

  • User-783820979 posted

    Finally figured this one out.

    Let me introduce you to MSHelp 3.0 :)

    Looks like Help in 2010 is provided by a webserver that opens up on port 80. I just happened to have hit F1 before trying to serve my site from port 80.

    Of course once I serve my site from Port 80, Help in VS2010 no longer works :).

    Hope this can help someone else.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 4, 2010 7:22 PM

All replies

  • Wednesday, December 30, 2009 9:48 PM
  • User-783820979 posted

    Yeah I had run across that document when trying to solve this myself. It doesn't seem to apply, I don't have any  "open connections that aren't established".

    I'm probably showing some ignorance here :) but why does the System have port 80 open, and can more than one process open a port?

    Thursday, December 31, 2009 4:22 PM
  • User-783820979 posted

    Still hoping to get an answer here. 

    Monday, January 4, 2010 1:29 PM
  • User-783820979 posted

    Finally figured this one out.

    Let me introduce you to MSHelp 3.0 :)

    Looks like Help in 2010 is provided by a webserver that opens up on port 80. I just happened to have hit F1 before trying to serve my site from port 80.

    Of course once I serve my site from Port 80, Help in VS2010 no longer works :).

    Hope this can help someone else.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Monday, January 4, 2010 7:22 PM
  • User1415983342 posted

    How can this problem be reproduced? 
    I do not observe anything similar

    before trying to serve my site from port 80.

    Is not port 80 default one?
    to server by default ASP.NET development server or by IIS?

    Tuesday, January 5, 2010 1:00 AM
  • User-783820979 posted

    I was able to reproduce this problem by.

    1. Start VS 2010
    2. Push F1 (starts help web-server on port 80)
    3. "Run" my web site on port 80 
    Tuesday, January 5, 2010 2:08 PM
  • User956740506 posted

    In my case it was because Web Deployment Agent Service (remote agent service for Web Deploy 2.0) was running. Unfortunately it's hard to track down which service/app has port 80 open the reported PID is (SYSTEM) because all services who use HTTP.SYS will show up as SYSTEM having port 80 open.

    Friday, January 27, 2012 4:32 AM
  • User1673853347 posted

    I had same issue and wasted my time in resolving it....

    May be this solution could help others....

    Right Click on project - Select 'Properties' - Select Tab 'Web' - In this tab under 'Servers' select option Auto-assign port .

    Then save changes.. close you project and again open it. 

    and now try building and running the solution.

    This worked for me.

    Tuesday, January 22, 2013 4:01 AM