none
dfsvc.exe crash when trying to install a App RRS feed

  • Question

  • Hi all,

    I'm having troubles with .Net Framework when I try to install a App, dfsvc.exe crashing.
    I'm posting below a few screenshots:

    http://img11.imageshack.us/img11/4689/neterror3.jpg

    http://imageshack.us/a/img211/5135/neterror.jpg

    http://imageshack.us/a/img694/8937/neterror2.jpg

    If you could help me this one, thank you.

    OS: Windows Server 2008 R2



    ...



    • Edited by EugenX Wednesday, November 14, 2012 8:05 AM
    Wednesday, November 14, 2012 8:03 AM

Answers

  • I have finally solved the issue, I had to copy the files and some registry keys from the working account to others accounts and now the application is working for everyone.  Thank you pvdg42 for trying  to help.

    ...

    Friday, November 16, 2012 12:46 PM

All replies

  • It appears that .NET Framework 4.0 is involved in your scenario.

    Please check the status of your .NET 4.0 installation with this tool:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with .NET Framework 4.0 selected, then paste the first 15 lines AND the last 15 lines of the tool log here.

    Wednesday, November 14, 2012 3:40 PM
  • Net 4.0 is certainly involved in this situation.

    Here is the log when choosing .NET 4.0 Client:

    http://www.pastebin.ca/2251752

    And here is the log when choosing .NET 4.0 FULL:

    http://www.pastebin.ca/2251757

    Thank you.


    ...

    Thursday, November 15, 2012 10:27 AM
  • According to the logs, both your .NET Framework 4.0 Client Profile an .NET Framework Full verify as correctly installed and configured.

    What is the application you are trying to install when your issue occurs?

    Thursday, November 15, 2012 1:12 PM
  • It's a program developed by a local company, I had successfully install it on Windows 8 x86 and Windows Server 2003 X64, but can't install it on my Terminal Server running Windows Server 2008 R2.

    Any help would be appreciated.


    ...

    Thursday, November 15, 2012 3:18 PM
  • I suggest you contact the local company's tech support and ask them about this situation on the one machine.

    The test results on .NET Framework 4.0 would indicate the issue is elsewhere.


    If you disagree, you can try a repair on .NET 4.0, and if that does not help, remove 4.0 and reinstall.
    • Edited by pvdg42 Thursday, November 15, 2012 8:28 PM
    Thursday, November 15, 2012 8:26 PM
  • Actually I've managed yesterday to install the application, but only when logged as local Administrator and when I made some changes in IE, but still can't install it logged as Domain Administrator, the only reason I can think off why it doesn't want to install is that all other Domain Users including the Domain Administrator have their Profiles on another partition(location) "F:\Profiles" and not the default one "C:\Users"...and the thing is that this application has to be installed on every account, not like normal programs, once installed in Program Files it is accessible for all users.

    Don't know where should I dig to find a solution...



    ...




    • Edited by EugenX Friday, November 16, 2012 7:38 AM
    Friday, November 16, 2012 7:33 AM
  • I have finally solved the issue, I had to copy the files and some registry keys from the working account to others accounts and now the application is working for everyone.  Thank you pvdg42 for trying  to help.

    ...

    Friday, November 16, 2012 12:46 PM