none
Signing Tab not showing up in solution properties in visual basic 2015

    Question

  • I had an install of visual studio 2015.  I had problems and had to reset the computer.  I installed Visual Studio on a fresh build of Windows 10. I could not get a project to publish.  I checked and I had installed "click once".  I did a "repair" with the Visual Studio Install program and still no luck.  I have googled the problem but I can't find an answer. 

    Any help would be appreciate.

    Wednesday, September 14, 2016 2:25 AM

Answers

All replies

  • Hi Cal,

    Welcome to the MSDN forum.

    What’s the project template that you created? The Publish that you mentioned is stands for the right-click the project name—Publish or Publish tab in the Properties page? For the project type like class library, it not have the Publish option, for the web project type, it should have the Publish option.

    Please have a try with the following to excludes some settings or data use in VS caused this issue:

    1.  Please open an administrative CMD window and navigate to C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE and run these commands as below, then open VS. What’s more, please check here: https://msdn.microsoft.com/en-us/library/xee0c8y7.aspx
      devenv /resetsettings: reset the setting to exclude the old settings effects this option
      devenv /resetuserdata: clean up the old user data
      devenv /safemode: run the VS with safe mode to exclude the effect of the installed extensions or other add-in factors
    2. Run the VS as administrator and see if the same issue still persists, it will help us to eliminate the possibility of the permission issue.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Langerz Wednesday, February 14, 2018 8:28 AM
    Wednesday, September 14, 2016 9:36 AM
    Moderator
  • devenv.exe not located in Visual Studio 12.0\Common7\IDE.  It is located in the Visual Studio 14.0 corresponding location.

    I ran all the devenv with all of the options you required, in the order you required as administrator.  The Developer IDE came up in safe mode.  Still no code signing tab.  I ran the Developer IDE as admininistrator and still no signing tab.  I am inserting a copy of what the Solution Properties looked like

    I tried to send you an image of the print screen of Solution Properties.  It said my account hadn't been verified, so no copy of the screen.  How do I fix that? 

    I programmed in Visual Basic 6 many years ago and wrote some pretty cool programs for pharmacies, schools, and hospitals.  I haven't coded in years but have a program I desperately need to rewrite.    I am not sure that we are moving forward.  I can't even get the IDE to work. 

    We don't have it running properly yet, but I do appreciate your help.

    Cal

    Thursday, September 15, 2016 4:05 AM
  • Signing tab appeared this morning.  Not sure exactly what happened.  I appreciate all of your help.

    Cal

    Thursday, September 15, 2016 4:52 PM
  • Hi Cal,

    I'm glad that this issue has gone.

    Since this issue is gone, I suggest you mark your reply as answer to close this thread.

    If any other questions about Visual Studio IDE, please feel free to come back create new thread.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, September 16, 2016 6:22 AM
    Moderator
  • I wasnt getting the Signing tab, and a couple of others. This fixed it thank-you!! ^-^
    Wednesday, February 14, 2018 8:28 AM