locked
Error on Splash Screen - The Application didn't start RRS feed

  • Question

  • Since upgrading to Windows 8.1 recently, I haven't been able to deploy/debug my application through Visual Studio 2012. It builds fine but as soon as it's launched it hangs on the splash screen and I see this error in the background.

    Unable to activate Windows Metro style application 'The app didn't start'

    I tried the advice from this previous thread, including deleting all bin and obj folders and re-installing Visual Studio (I also tried installing Visual Studio 2013 but the issue is the same) and making sure there are no other versions of the app installed. In addition when I pulled the source straight from source control it doesn't make a difference. I also tried creating the projects from scratch again but to no avail. 

    However after a lot of trial and error I found I was able to get the application to deploy properly when I created a new publisher certificate with a different publisher ID. But if I use the correct publisher ID (the one connected to the Windows Store account) then it fails with the same error. I've tried deleting all instances of any certificate file with that publisher ID on my machine but it doesn't seem to make any difference. I can create an appx package with the original certificate and that installs that installs and runs ok.

    I can work around the issue for the moment by using a publisher certificate locally for the moment but I really lost as to why this is happening on my machine. Any suggestions would be greatly appreciated


    • Edited by rshortall Friday, November 15, 2013 3:37 PM
    Friday, November 15, 2013 3:34 PM

All replies

  • If you can get a dump of the process when it crashes, please do so and post a link to it here.  Otherwise, I recommend that you open a support case for assistance and we can walk you through the issue.


    Matt Small - Microsoft Escalation Engineer - Forum Moderator
    If my reply answers your question, please mark this post as answered.

    NOTE: If I ask for code, please provide something that I can drop directly into a project and run (including XAML), or an actual application project. I'm trying to help a lot of people, so I don't have time to figure out weird snippets with undefined objects and unknown namespaces.

    Tuesday, November 19, 2013 1:46 PM
    Moderator
  • Thanks for your reply - I've had no luck generating a dump file unfortunately. I've followed the steps here for creating the needed keys in HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\Windows Error Reporting\LocalDumps, however nothing gets generated when the error occurs and I clear the dialog.

    Is this the correct method to create a dump file? I have also tried running Procdump.exe but it also doesn't generate a dump file. It does launch my app and it gets as far as the splash screen and the previous error but dump file.

    Is there anything else I can try?

    Thanks for your help!

    Tuesday, December 3, 2013 11:37 AM