locked
Unable to load add-in registered under HKLM for MS Project 2007. RRS feed

  • Question

  • Hi,

    I have developed an Add-In for MS Project. The add-in is working fine for MS Project 2010 as the add-in is registered under HKLM, but when i try to load an add-in for MS Project 2007 the "LoadBehavior" value changes from 3 to 0, so i was trying apply the above mentioned hofix (office-kb976477) in order to get add-in worked for MS Project 2007.

    But i am not able to install this hofix on my machine, it shows the message "The expected version of the product was not found on the system." when i try to install the hotfix.

    I tried to resolve the problem by installing "Microsoft Office suite Service Pack 2" as it is mentioned at support.microsoft.com/.../976477 and then applied the hotfix but it gives the same message.

    There is Microsoft Office Standard 2007 and Microsoft Office Project Standard 2007 installed on my machine.

    Any idea/suggestions?

    Thanks,

    -A-B-


    • Edited by -A-B- Monday, August 20, 2012 9:21 AM
    Monday, August 20, 2012 9:17 AM

Answers

  • have you tried setting EnableLocalMachineVSTO to 1 for your project in registry?
    • Marked as answer by -A-B- Tuesday, August 28, 2012 10:26 AM
    Monday, August 27, 2012 2:36 PM

All replies

  • have you tried installing SP3 for project? http://www.microsoft.com/en-us/download/details.aspx?id=27811 

    • Marked as answer by Leo_Gao Friday, August 24, 2012 1:26 AM
    • Unmarked as answer by -A-B- Monday, August 27, 2012 1:39 PM
    Monday, August 20, 2012 9:48 AM
  • Thanks DaminD for reply but still not able to load an add-in even after installing SP3 for project at  http://www.microsoft.com/en-us/download/details.aspx?id=27811 .

    And the behavior is same as it was that is the "LoadBehavior" value changes from 3 to 0 in the registry for MS Project 2007.

    Also in "COM Add-Ins" dialog of MS Project, my add-in remains unchecked and its load behavior is as,

    Load Behavior :  Unloaded.

    Monday, August 27, 2012 1:53 PM
  • have you tried setting EnableLocalMachineVSTO to 1 for your project in registry?
    • Marked as answer by -A-B- Tuesday, August 28, 2012 10:26 AM
    Monday, August 27, 2012 2:36 PM
  • Yes, i added EnableLocalMachineVSTO to the registry at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\12.0\Common\General

    and set it to 1, the add-in is getting loaded and working fine now.

    Thanks DamianD for your suggestion.

    Tuesday, August 28, 2012 10:33 AM