none
Configuring Custom Domain for Azure DNS

    Question

  • I have created a custom web application using c# .net framework 4.6.1. I have hosted the site via Azure, and have created a DNS for the website. The domain I wish to be using was purchased through Google Domains. Currently, I am trying to configure the custom domain so that my domain name is connected to the hosted site.

    I have followed the documentation found at: https://docs.microsoft.com/en-us/azure/app-service/app-service-web-tutorial-custom-domain#cname

    When I attempt to add a host name, I enter the domain name I purchased through google (www.<domain name>.com), click Validate, and I receive a warning at the bottom of the screen under Domain Ownership. It tells me to "Create an CNAME record with your DNS provider using the configuration below" and shows me the configuration I need for my CNAME.

    I have set up the exact CNAME that Azure has told me to set up on my google domain. The site is still not working.

    I have attempted to contact support, but have not had any luck.

    Ideally, I would like someone at Azure to look at my configuration and tell me what I am doing wrong, but if anyone has any idea, I am all ears.

    Thanks in advance.

    Friday, January 11, 2019 12:26 AM

Answers

  • Hi Cstalder, 

    I did a repro this morning and it works fine for me. Here is what I did:

    Created a web App : karthik1.azurewebsites.net

    Created a domain karthiks.ddns.net

    In my registrar, I created a CNAME as follows.

    

    In the Web App, just added the custom Domain as follows:

    It works!! Hope this helps

    Saturday, January 12, 2019 5:06 AM
    Moderator

All replies

  • Hi Cstalder, 

    This validation is to verify whether you own this domain or not. So when you go with map CNAME method, you need to create a CNAME record in your registrar mapping www.yourdomain.com to xyz.azurewebsites.net

    Once this is done, it may take a while for this changes to populate across. So, can you try validating after few hours of adding CNAME and check if that works?

    Hope this helps!


    Friday, January 11, 2019 2:07 AM
    Moderator
  • Hey msrini,

    So, after a day, it is still not working. I obviously am doing something wrong, but I can't figure out for the life of me what it is. The domain I purchased is through Google Domains. I have created a Custom Resource record there like the following:

    Name: www

    Type: CNAME

    TTL: 1h

    Data: <hostname assigned to the site via azure>.azurewebsites.net

    The record saved with google domains, but when I go to azure's portal->the app service->Custom Domains->Add hostname and enter the purchased domain name (www.<google domain name>.com) it still fails validation. 

    Saturday, January 12, 2019 12:20 AM
  • Hi Cstalder, 

    I did a repro this morning and it works fine for me. Here is what I did:

    Created a web App : karthik1.azurewebsites.net

    Created a domain karthiks.ddns.net

    In my registrar, I created a CNAME as follows.

    

    In the Web App, just added the custom Domain as follows:

    It works!! Hope this helps

    Saturday, January 12, 2019 5:06 AM
    Moderator
  • Hi Cstalder, 

    Any update on this issue?

    -----------------------------------------------------------------------------------------------------------

    If you found this post helpful, please give it a "Helpful" vote. 

    Please remember to mark the replies as answers if they help.

    Friday, January 18, 2019 4:50 AM
    Moderator