none
TP4 can not download WindowsServerCore image through install-containerimage RRS feed

  • Question

  • I can not download WindowsServerCore image through install-containerimage!! I have tried for many times. But i always get errors below before the Bitstransfer download the full image. I think it is the network that cause the problem as i am chinese in china, i have tried connect to internet through different vpns, but the result is sad. Is there any way i could get the windowservercore image? I really want to try the windows docker.

    thanks a lot.

    Start-BitsTransfer : 与服务器的连接意外终止 (Connection with server terminated unexpectedly)
    所在位置 C:\Program Files\WindowsPowerShell\Modules\ContainerProvider\0.5.2\ContainerProvider.psm1:520 字符: 9
    +         Start-BitsTransfer -Source $downloadURL `
    +         ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : InvalidOperation: (:) [Start-BitsTransfer],Exception
        + FullyQualifiedErrorId : StartBitsTransferCOMException,Microsoft.BackgroundIntelligentTransfer.Management.NewBits
       TransferCommand

    Get-WindowsImage : 系统找不到指定的文件。(The system could not find the file specified)
    所在位置 C:\windows\system32\windowspowershell\v1.0\Modules\Containers\1.0.0.0\Containers.psm1:38 字符: 29
    + ... ageInfo = @(Get-WindowsImage -ImagePath $WimPath -LogPath ($env:temp+ ...
    +                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
        + CategoryInfo          : NotSpecified: (:) [Get-WindowsImage], COMException
        + FullyQualifiedErrorId : Microsoft.Dism.Commands.GetWindowsImageCommand

    Tuesday, March 15, 2016 12:58 PM

Answers

All replies

  • Please setup an anti-censorship infrastructure like Shadowsocks.
    Tuesday, March 15, 2016 1:32 PM
  • thanks, i will try it.
    Wednesday, March 16, 2016 10:41 AM
  • I finally download the image manully through Thunder from:

    https://pshctnoncdn.blob.core.windows.net/pshctcontainer/CBaseOs_th2_release_10586.0.151029-1700_amd64fre_ServerDatacent
    erCore_en-us.wim?sv=2015-02-21&sr=b&sig=rLNvGpycEElTr52U6EwrMmnzSRVbsCSIEuO%2B7oa8HYI%3D&st=2015-11-17T22%3A57%3A58Z&se=2016-11-17T22%3A57%3A58Z&sp=r

    and put the wim file at :

    C:\Users\ADMINI~1\AppData\Local\Temp\WindowsServerCore.wim

    then comment out the

    #Start-BitsTransfer -Source $downloadURL -Destination $destination

    in ContainerProvider.psm1

    after re-executing "install-containerimage -name WindowsServerCore"

    I finally install the windowsservercore image, and can start the container though powershell cmd successfully.

    there is just one problem remain that i can not get the image through "docker images"

    Is there any one could help me?

    thanks

    Monday, March 21, 2016 2:55 AM
  • If the image shows using ‘Get-ContainerImage’ but not with ‘Docker Images’, then you will most probably need to re-start the docker service.

    You will also most likely want to tag the images for use with Docker, here are some details around this - https://msdn.microsoft.com/en-us/virtualization/windowscontainers/management/manage_images#tag-images .

    Thanks

    neilp   

    • Marked as answer by TheSeaOfStars Wednesday, March 23, 2016 3:14 AM
    Tuesday, March 22, 2016 1:56 AM
  • it works

    Thanks :)

    Wednesday, March 23, 2016 3:14 AM