none
wcf-sql adapter timeout error RRS feed

  • Question

  • hi ,

    i am using wcf-sql adapter to receive the data from the db, when the data in the db is in Kb's then it is processing fine,But when the size of the data increasing to Mb's then i am getting timeout error . please suggest me to resolve this issue.

    Thanks in Advance

    Panadi


    • Edited by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:07 PM

Answers

  • Hi,

    Not sure why you don't want to increase the time, when you have a timeout problem (?) As you can see in this MSDN article, Microsoft recommends setting the ReceiveTimeout to the maximum to avoid issues:

    For inbound operations such as polling, we recommend setting the timeout to the maximum possible value, which is 24.20:31:23.6470000 (24 days). When using the adapter with BizTalk Server, setting the timeout to a large value does not impact the functionality of the adapter.


    Best regards, Kjetil :) Please remember to click "Mark as Answer" on the post that helps you. This can be beneficial to other community members reading the thread.

    • Proposed as answer by Maheshkumar S Tiwari Thursday, January 7, 2016 2:59 PM
    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:28 PM
  • Hi,

    Why not suggest for increase in time ? Any specific reason ? Anyways there are lot of things apart from increasing the time that you could do :

    - Set receiveTimeout to the maximum time 24.20:31:23.6470000.
    - Place WCF-SQL receive locations in separate host to provide its own thread pool and eliminate impact on other processes
    - Ensure WCF-SQL dedicated host instances are restarted at interval less or equal to receiveTimeout to flush threads and memory
    - Monitor performance counters Process/Thread Count/BTSNTSvc{n} for thread count trend and respond to alert if it grows by restarting host instance.

    Refer the below article for detailed explanation :

    http://geekswithblogs.net/paulp/archive/2010/05/17/139876.aspx

    Please indicate "Mark as Answer" or "Mark as Helpful" if this post has answered the question

    Regards

    Rahul Madaan

    biztalkvillage.blogspot.com

    • Proposed as answer by Maheshkumar S Tiwari Thursday, January 7, 2016 2:59 PM
    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:29 PM
  •  please suggest me to resolve this issue. please do not suggest to increase the time.


    Why can't you increase the timeout?  The more data there is, the more time it takes, that's a pretty straight forward situation.

    You only other option then is to change how the Stored Procedure works to return only a limited set of data, TOP 10/100/1000, whatever is comfortably below the limit.  This is probably a good idea anyway, regardless of the current timeout.

    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:35 PM
    Moderator

All replies

  • Hi,

    Not sure why you don't want to increase the time, when you have a timeout problem (?) As you can see in this MSDN article, Microsoft recommends setting the ReceiveTimeout to the maximum to avoid issues:

    For inbound operations such as polling, we recommend setting the timeout to the maximum possible value, which is 24.20:31:23.6470000 (24 days). When using the adapter with BizTalk Server, setting the timeout to a large value does not impact the functionality of the adapter.


    Best regards, Kjetil :) Please remember to click "Mark as Answer" on the post that helps you. This can be beneficial to other community members reading the thread.

    • Proposed as answer by Maheshkumar S Tiwari Thursday, January 7, 2016 2:59 PM
    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:28 PM
  • Hi,

    Why not suggest for increase in time ? Any specific reason ? Anyways there are lot of things apart from increasing the time that you could do :

    - Set receiveTimeout to the maximum time 24.20:31:23.6470000.
    - Place WCF-SQL receive locations in separate host to provide its own thread pool and eliminate impact on other processes
    - Ensure WCF-SQL dedicated host instances are restarted at interval less or equal to receiveTimeout to flush threads and memory
    - Monitor performance counters Process/Thread Count/BTSNTSvc{n} for thread count trend and respond to alert if it grows by restarting host instance.

    Refer the below article for detailed explanation :

    http://geekswithblogs.net/paulp/archive/2010/05/17/139876.aspx

    Please indicate "Mark as Answer" or "Mark as Helpful" if this post has answered the question

    Regards

    Rahul Madaan

    biztalkvillage.blogspot.com

    • Proposed as answer by Maheshkumar S Tiwari Thursday, January 7, 2016 2:59 PM
    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:29 PM
  •  please suggest me to resolve this issue. please do not suggest to increase the time.


    Why can't you increase the timeout?  The more data there is, the more time it takes, that's a pretty straight forward situation.

    You only other option then is to change how the Stored Procedure works to return only a limited set of data, TOP 10/100/1000, whatever is comfortably below the limit.  This is probably a good idea anyway, regardless of the current timeout.

    • Marked as answer by panadi Friday, January 8, 2016 12:19 PM
    Thursday, January 7, 2016 12:35 PM
    Moderator
  • hi Rahul,

    Thanks for the reply.

    Is there any other way to overcome this issue?

    Thanks

    Panadi

    Thursday, January 7, 2016 2:12 PM
  • Hi,

    I am not sure of other resolution apart from mine's and John's suggestion but why not go with increasing the timeout ? Any specific reason ?

    Please indicate "Mark as Answer" or "Mark as Helpful" if this post has answered the question.

    Regards

    Rahul Madaan

    biztalkvillage.blogspot.com

    Thursday, January 7, 2016 2:26 PM
  • Is there any other way to overcome this issue?

    You have to answer our questions to get the best advice.

    Why can't you increase the timeout?

    You have only two realistic options:

    1. Increase the Timeout.

    2. Decrease the potential volume by altering the Stored Procedure.

    Thursday, January 7, 2016 2:36 PM
    Moderator
  • Hi Panadi,

    Thank you for posting in MSDN forum.

    As others suggestion, the best solution is increase the time which is 24.20:31:23.6470000 (24 days). And this is very simple and not will impact.


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, January 7, 2016 5:38 PM
    Moderator