locked
DataGridView rendering ok in IE and Edge but not Chrome RRS feed

  • Question

  • User40824879 posted

    Hi,

    In all three browsers, I can see the data in its entirety (same for all three browsers) but Chrome does not render it. There doesn't appear to be any CSS properties hiding the gridview either since it would affect it in IE and Edge. Also, no errors are given in the console within the browser tools.

    Any general thoughts or ideas that could be causing this?

    Thanks,

    JW25

    Tuesday, March 19, 2019 12:52 PM

All replies

  • User753101303 posted

    Hi,

    And you tried https://developers.google.com/web/tools/chrome-devtools/inspect-styles/ as well ? It should make quite easy to find out what happens and you can even disable or change rules to see what happens and confirm your findings...

    Tuesday, March 19, 2019 1:12 PM
  • User40824879 posted

    Thanks for your response. Yes, unfortunately I have tried that, with no luck. I will note though that when I hover over elements in the source in the Chrome DevTools, I see it highlight blank spaces (where the data should be appearing). No amount of changing elements has worked so far.

    Tuesday, March 19, 2019 1:27 PM
  • User753101303 posted

    visibibility:hidden maybe ? It hides an element while preserving the space it would take. Or maybe something wrong with a color or a transparency value. At worst if you disable CSS rules one by one the element should end up being shown again (unless it is really some kind of rendering bug ???)

    IMO trying to guess will be longer anyway than inspecting your page using this kind of tool.

    Tuesday, March 19, 2019 1:40 PM
  • User40824879 posted

    I will search on the things you have mentioned. My guess is that it is something silly easy and I'm just not spotting it. I have now come across something that is missing in Chrome. I'll be honest, I'm not sure what a WebResource is as I come from an MVC background. Could this be a potential culprit?

    ctl00_Menu1_Data.iframeUrl = '/WebResource.axd?d=m2qqV2NmYhk7t6bS6blvXPL-0QL4Pc4_kKrPW8euSi3nlivAPYWRBKnl7bb0ehoKfxbsRrMGQsxJ2JUQcFA8xFPUJD2gxS_VLcRx2nX7tVQ1&t=636765283264470882';

    The only other difference is Chrome encodes the space character in some instances

    Tuesday, March 19, 2019 1:50 PM
  • User753101303 posted

    This is something rendered dynamically or what ? My first step when I don't see something is to use "view source" to see if the expected HTML markup is part of my page. If yes, then you really must have some CSS rule hiding this area...

    If dynamically rendered using JavaScript it coould be for example that the code stops if not finding something rather than causing an error (as it seems the Console doesn't show anything special).

    Edit : with WebForms if the Visible property is false the HTML markup is not rendered at all to the page (and for example JavaScript trying to show that will fail).

    Tuesday, March 19, 2019 2:27 PM
  • User475983607 posted

    Turn off all Chrome extensions and retry.

    Tuesday, March 19, 2019 2:41 PM
  • User40824879 posted

    Hi, I do not have an Chrome extensions at this time

    Tuesday, March 19, 2019 3:42 PM
  • User40824879 posted

    That I am not sure of but I will explore everything and reply back later. I'm hoping it turns out to be just a simple property that I've overlooked a couple of times.

    Tuesday, March 19, 2019 3:44 PM
  • User-943250815 posted

    JW25

    I'm not sure what a WebResource is

    There is nothing wrong with WebResource.axd, it is normal on webforms, here you can get a little more about it http://scottonwriting.net/sowblog/archive/2010/10/28/just-where-is-webresource-axd.aspx

    JW25

    I can see the data in its entirety (same for all three browsers) but Chrome does not render

    Did you made an attempt without any CSS, from style sheet file or inline, just to be sure it is not a CSS issue?
    In past I had a similar issue with Chrome, it was related the way Chrome caches page, even using a dynamic page content, page was not loaded as supposed.
    Solution was Ctrl+Shif+R or Shift+F5 (Reload your current page, ignoring cached content)

    Tuesday, March 19, 2019 10:29 PM
  • User-893317190 posted

    Hi JW25,

    What's your DataGridView like?

    If it is complex, try to simplify it and restart chrome to see whether chrome shows the data so that you could find out what causes the problem.

    Simple gridview should not cause this problem , it is hard to guess what your problem is without your code.

    Best regards,

    Ackerly Xu

    Wednesday, March 20, 2019 4:04 AM