none
Access 2016 SHOWPLAN doesn't output RRS feed

  • Question

  • All,

    I have just upgraded to access 2016, and cannot invoke the query engine SHOWPLAN out. I have searched all forums that I could find and tried to implement suggested solutions, but all to no avail. I have windows 7 64-bit, and am running 32-bit office.

    I have created/enabled the key HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\14.0\Access Connectivity Engine\Engines\Debug and then the string JETSHOWPLAN = ON.

    There is no access connectivity key in the 15.0 or 16.0 key's. 

    I have checked, documents, current directory, etc and found no SHOWPLAN.OUT file. Any Suggestions?

    Thursday, April 27, 2017 2:25 AM

All replies

  • Hi honel,

    We are trying to make testing on our side.

    we are facing some issues in testing.

    I try to include some senior engineers to look in to this issue.

    further they will try to make test and once we complete it successfully we will get back to you with appropriate suggestion to solve the issue.

    Thanks for your understanding.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 28, 2017 7:14 AM
    Moderator
  • Deepak,

    Thanks for the prompt response. Do you have any sort of timeline? I have some query issues that I am trying to resolve/optimize and without access to the showplan I am at a bit of a loss as to what the engine is doing.

    Thanks

    Honel

    Monday, May 1, 2017 7:14 AM
  • Hi honel,

    generally , it takes some more time to get response from senior engineers.

    then also I will try to make the test again and try to take help from them to make it work.

    I will inform you about my testing results.

    last time when I try to add JETSHOWPLAN in registry then the issue was there is no Debug folder available on that path to add JETSHOWPLAN.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, May 1, 2017 9:37 AM
    Moderator
  • The key itself might not exist and you need to create it and then add the String Value JETSHOWPLAN with a value of ON.

    Also, if you are using a CTR version (office365) I had to use the following key

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\16.0\Access Connectivity Engine\Engines\Debug

    to get it all functional.  See: https://www.devhut.net/2011/04/30/ms-access-jet-showplan/

     

    What I'd recommend is searching for "Access Connectivity Engine" because that key will exist and then go form there. The "Access Connectivity Engine" key will exist in more than one location, so you need to be sure to locate the one that has "Engines" as a key within in.  That will be the one to add the Debug key to...

     

    Why, oh why, after all these years this is not an option through the GUI still eludes me!


    Daniel Pineault, 2010-2016 Microsoft MVP
    Professional Support: http://www.cardaconsultants.com
    MS Access Tips and Code Samples: http://www.devhut.net





    Monday, May 1, 2017 1:29 PM
  • Hi honel,

    I try to add string value in locations below.

    \\HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Jet\4.0\Engines


    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\12.0\Access Connectivity Engine\Engines\Debug


    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\15.0\Access Connectivity Engine\Engines\Debug

    nothing works on my side.

    I also try to add key to path below.

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\16.0\Access Connectivity Engine\Engines

    but on my side there is no "Access Connectivity Engine" in 16.0.

    I try to reopen database and try to run the query and check the Mydocuments folder.

    but there is no SHOWPLAN.OUT there.

    there is no official documentation available for SHOWPLAN.

    I will try to search further and let you know if I find something useful.

    Regards

    Deepak


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, May 2, 2017 9:40 AM
    Moderator