locked
How can I pass a mulit Parameter list to a sub report RRS feed

  • Question

  • Hi,

    From the front end of the application we are going to be a building a string like '3825,3831' and passing to my report as sis_Id. My report has a sub report in it... and when i try to pass the parameter it says first (fieldname!value ,"dataset") instead of just showing the value

    When they pass the parameter list to my main report should I have the Allow mulitple values checked in my report? when i run my procedure I get the correct results but when i run my report I get same data report a lot of times?

    Any help will be appreciated.

    Thanks

    Karen

     

     

    Tuesday, August 30, 2011 9:05 PM

Answers

  • Hi Karen

    Please go through this

    It may help you..!!!

    http://social.msdn.microsoft.com/forums/en-US/sqlreportingservices/thread/ae5ac615-1076-428d-9fcf-6c27e5fee1f0/

    • Marked as answer by Karenros Wednesday, August 31, 2011 5:47 PM
    Tuesday, August 30, 2011 9:54 PM

All replies

  • Hi Karen

    Please go through this

    It may help you..!!!

    http://social.msdn.microsoft.com/forums/en-US/sqlreportingservices/thread/ae5ac615-1076-428d-9fcf-6c27e5fee1f0/

    • Marked as answer by Karenros Wednesday, August 31, 2011 5:47 PM
    Tuesday, August 30, 2011 9:54 PM
  • I took a look at the post but since i am passing the parameters from the application? would the making the parameter as multi value parameter work?
    Wednesday, August 31, 2011 12:46 PM
  • Sorry ... got it to work User error (insert shy symbol here) i was giving first(fieldname.value) so it was displaying the first record always :)
    Wednesday, August 31, 2011 3:31 PM