none
Hide Advanced Members - Visual Studio (2015) WON'T remember this setting

    Question

  • I have tried everything left and right but VS2015 Enterprise NEVER remembers this setting.  I want to see ALL properties and methods for an object when I hit the period (.), but EVERY time i load up VS2015 I have to go to Options, Text Editor, C#, General and UNCHECK the "Hide Advanced Members" check box.

    I have Unchecked it and then immediately saved the C# node from the settings.

    in the settings file (after unchecking the check box) the line exists:  <HideAdvancedMembers>true</HideAdvancedMembers>  So even when I uncheck it, VS doesn't save the value correctly.  I manually change that true to a false in the vssettings, and it makes no difference.  VS doesn't load that setting at all.

    Has this been identified or resolved anywhere?

    Thanks

    Jaeden "Sifo Dyas" al'Raec Ruiner


    "Never Trust a computer. Your brain is smarter than any micro-chip."
    PS - Don't mark answers on other people's questions. There are such things as Vacations and Holidays which may reduce timely activity, and until the person asking the question can test your answer, it is not correct just because you think it is. Marking it correct for them often stops other people from even reading the question and possibly providing the real "correct" answer.

    Wednesday, March 1, 2017 5:08 PM

All replies

  • Hi JaedenRuiner,

    Please share me which place of <HideAdvancedMembers> you are searching for? (There are 22 <HideAdvancedMembers> nodes)

    In my side, I modified that options and compared the <HideAdvancedMembers> node in settings file, I get the following difference:

    And there other 21 <HideAdvancedMembers> nodes are same. So please compare the setting before and after enable that option based on my above screenshot: Ln:1 Col:23615

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.


    Thursday, March 2, 2017 5:52 AM
    Moderator
  • Hi friend,

    If my reply help you resolved your doubts, please remember to mark it, which could be helpful for others that have the same issue. Thank you very much. :)

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 3, 2017 6:24 AM
    Moderator
  • All of them.

    But for my circumstance I am simply worried about C# for now.

    However, that being said.  The problem doesn't matter the XML.  It's Visual Studio itself.

    I change the setting in the Tools | Options | Text Editor.

    I IMMEDIATELY EXPORT via Tools | Import and Export.

    I close down visual studio. 

    I restart.

    Tge Setting is set to True again.

    I load the recently exported settings (after I changed the setting) and the setting is still TRUE.

    So regardless of what the XML (vssettings) file says, Visual Studio 2015 @#$%ing ignores this setting.

    Thanks

    J"SD"a'RR


    "Never Trust a computer. Your brain is smarter than any micro-chip."
    PS - Don't mark answers on other people's questions. There are such things as Vacations and Holidays which may reduce timely activity, and until the person asking the question can test your answer, it is not correct just because you think it is. Marking it correct for them often stops other people from even reading the question and possibly providing the real "correct" answer.

    Friday, March 10, 2017 9:48 PM
  • Hi friend,

    I will try your description in my side, and update my results.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, March 13, 2017 9:52 AM
    Moderator
  • Hi J"SD"a'RR,

    I have tried your description, it is fine in my side. I think you have ignored some steps, please refer to the following steps:

    1). uncheck this option, and save vssettings file as uncheck.vssettings. (Export)

    2). check this option, and save vssettings file as chech.vssettings. (Export)

    3). Then you could verify this two settings file. Please import them separately and check the results. (Import)

    Plus:

    Please pay attention to Import and Export. First, we need to Export the settings and name them. Then we just need to Import them and no do save the current settings.

    Sincerely,
    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.



    Wednesday, March 15, 2017 7:04 AM
    Moderator
  • Hi friend,

    If my reply help you resolved your issue, would you please mark it as answer, if not, please feel free to let me know. Thank you very much.

    Sincerely,

    Oscar


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, March 17, 2017 9:54 AM
    Moderator