locked
Deployment failed. Architecture not supported. RRS feed

  • Question

  • User62378 posted

    Hi

    I am getting the below error while deploying..

    The package does not support the device architecture (x86). You can change the supported architectures in the Android Build section of the Project Options.

    Deployment failed. Architecture not supported.

    Tuesday, July 8, 2014 7:23 AM

Answers

  • User47762 posted

    Just in Case anyone got the same problem. You've to open the Options of the Droid Project. Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, October 16, 2014 8:50 AM

All replies

  • User56293 posted

    Have you changed the supported architecture as the error message suggests? If so, did this solve your deployment issue?

    Tuesday, July 8, 2014 7:26 AM
  • User62378 posted

    I have tried changing the traget Android Version. But no luck.

    If any thing else required please suggest

    Tuesday, July 8, 2014 7:36 AM
  • User47762 posted

    Just in Case anyone got the same problem. You've to open the Options of the Droid Project. Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Thursday, October 16, 2014 8:50 AM
  • User121411 posted

    Here's an updated screenshot. Choosing x86 will get your Xamarin Android Player emulators to work:

    Thursday, April 23, 2015 4:28 AM
  • User41075 posted

    Thank you. This was useful.

    Saturday, June 6, 2015 12:42 PM
  • User137650 posted

    Thank you this solved my issue!

    Wednesday, July 8, 2015 3:40 AM
  • User141237 posted

    Many thanks

    Tuesday, July 28, 2015 9:58 AM
  • User42522 posted

    It seems this issue keeps appearing infrequently after updating various modules. The update screenshot of @ClarkCole was helpful, though it is now a bit outdate with more checkboxes in it.

    Monday, August 3, 2015 12:23 AM
  • User149299 posted

    Oh my God! Thank you! It took me months to work it!

    Wednesday, November 4, 2015 12:50 PM
  • User144323 posted

    That's great, I too have the same problem. 1. Just changed Android Build -> Advanced tab -> armeabi-v7a and x86. It working fine for me.

    Saturday, November 7, 2015 2:12 PM
  • User174559 posted

    @FlorianZimmermann.7188 said: Just in Case anyone got the same problem. You've to open the Options of the Droid Project. Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    Very useful, thanks a lot!!!!

    Thursday, November 19, 2015 5:51 AM
  • User25759 posted

    Also, docs are here: https://developer.xamarin.com/guides/android/applicationfundamentals/cpuarchitectures/

    Thursday, November 19, 2015 7:04 AM
  • User68480 posted

    Thanks @JayakumarVnayagam, that got me going with Visual Studio's Android Emulator.

    @JamesMontemagno Wow I remember reading that a year or two ago and just not getting it. Now it makes perfect sense and addresses this problem. Sweet.

    Tuesday, December 8, 2015 3:19 PM
  • User177805 posted

    Guys i'm getting the same error in windows xamarin...........but in my xamarin 5 i dont have that android X86 options and all ....help

    Wednesday, December 9, 2015 11:30 AM
  • User223916 posted

    Thanks @ClarkCole.... A salute with gratitude...

    Friday, May 13, 2016 10:46 AM
  • User247750 posted

    Thanks - VS2015 -> project properties for my app -> Android Options -> Config=Release -> and then ticked all options, including "X86".

    And somehow, it now deploys to my Samsung Galaxy 5, no issue.......

    Wednesday, October 26, 2016 4:10 PM
  • User247750 posted

    Aahhhhh - I was deploying it to GenyMotion - which makes sense now why I needed the X86 option ticked.....

    Actually when I deploy to my own Samsung device, I don't need X86......

    Wednesday, October 26, 2016 4:20 PM
  • User117253 posted

    Thank you Clarkcole. This was useful.

    Tuesday, November 15, 2016 10:27 AM
  • User46127 posted

    it doesnt work for me,i have select all the arhitectures on both debhg and release but i canf deploy to genumotion in packaging on release everything is unchecked,i cant deploy either as debug ir release

    Thursday, December 1, 2016 11:16 PM
  • User229151 posted

    thanks for the fix, had a heart attack after all my apps failed to deploy

    Wednesday, December 21, 2016 4:24 AM
  • User284483 posted

    @FlorianZimmermann.7188 said: Just in Case anyone got the same problem. You've to open the Options of the Droid Project. Then go to Android Options -> Advanced and mark x86 while having 'Release' selected as Configuration.

    Very Useful Thank you..

    Tuesday, December 27, 2016 6:26 AM
  • User294135 posted

    Muchas gracias!!

    Tuesday, March 14, 2017 4:38 AM
  • User372303 posted

    This issue is because of wrong architecture selection in Android option. To select the corect archicture Please select the following options. 1. Right Click on Your Android Project. 2. Go to Properties 3. Select Android Option 4. Scroll down to see the Advance Option.click this Advance Option. 5. A popup will open with the supported acchicture. 6. Mostly X86 archicture will work,but you can try with other archicture also.

    Tuesday, August 28, 2018 5:31 AM
  • User380049 posted

    You Can look in the ToolBar items and Change the Realese To Debuge

    Monday, December 17, 2018 1:47 PM
  • User381074 posted

    thank you

    Monday, December 31, 2018 11:12 AM
  • User375562 posted

    Thank you.

    Tuesday, March 12, 2019 7:54 AM
  • User385830 posted

    Just change your build option from debug to release , normally happens when u want to test with emulator

    Thursday, May 23, 2019 6:05 AM
  • User392813 posted

    All I did is changing the "solution configuration" from "Release" to "Debug" TA-DA, it worked!!! - the project deployed successfully and reflected in the Emulator.

    Saturday, February 15, 2020 3:50 PM