none
Canonical URL issue RRS feed

  • Question

  • Hi, I've the next issue in a SP 2013 blog site:

    This blog has anonymous access enable, but I detect canonical URLs are incorrect, i.e. http://www.contoso.com/blog1/Lists/Blogentries/2_.000?ID=2.

    I want canonical URLs like http://www.contoso.com/blog1/Lists/Blogentries/post.aspx?ID=2.

    How can i get correct canonical URLs?

    Thanks in advance!!!


    Tomás González. Twitter://@tgmourino




    Wednesday, May 22, 2013 5:13 PM

All replies


  • 1. Select "Site Settings" 
    2. Select "Navigation" 
    3. Update Navigation Settings.  "Managed Navigation" for both the Global and Current Navigation options. 
    4. Term Store Management Tool 
    5. Select the Page 
    6. Select "Term-Driven Pages" option Tab. 
    7. Select the "Customize" option and update the term for the page and click save. 


    Aryan Nava | Twitter: @cloudtxt | Blog: http://virtualizesharepoint.com
    Please click "Propose As Answer" if a post solves your problem or "Vote As Helpful" if a post has been useful to you.

    Disclaimer: This posting is provided "AS IS" with no warranties.

    Wednesday, May 22, 2013 5:40 PM
  • Hi, your solution works in publishing pages, but this isn't the case.

    I resolved this issue hidding "additionalpagehead" controls.


    Tomás González. Twitter://@tgmourino

    Thursday, May 30, 2013 9:54 AM