none
Fatal error encountered in EDI Disassembler, error information is Edifact service schema not found RRS feed

  • Question

    • The error happened when I was trying to convert EDIFACT to XML under the direction of this article:

      msdn.microsoft.com\en-us\library\ff629677.aspx (please change \ to / because I can't post link)

      After the deployment, I received an error:

      A message received by adapter "FILE" on receive location "FabrikamReceiveLocation" with URI "D:\EDI\IN\AA\*.edi" is suspended. 
       Error details: An output message of the component "Microsoft.BizTalk.Edi.MessageCore" in receive pipeline "Microsoft.BizTalk.Edi.DefaultPipelines.EdiReceive, Microsoft.BizTalk.Edi.EdiPipelines, Version=3.0.1.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" is suspended due to the following error: 
           Edifact service schema not found.
       The sequence number of the suspended message is 1.  
       MessageId:  {C38D871A-1575-405A-9F43-AEDFE6047BC2}
       InstanceID: {F350042B-16AA-4EB5-A2D2-A5CBDE9DFA9C}

      When I test the sample, something couldn't be found which described in the article:

       7.Perform the following tasks on the Fabrikam->Contoso tab.
         c. On the Envelopes page under the Interchange Settings section, check Apply UNA segment (String service advice) and Apply UNG segments (Functional group header). I can't find the option Apply UNG segments (Functional group header)
      7.Perform the following tasks on the Fabrikam->Contoso tab.

         j. On the Envelopes page under the Transaction Set Settings section, enter values for all columns in the first line of the grid.
         Target namespace  Select http:\\schemas.microsoft.com\Edi\Edifact.(please change \ to / because I can't post link) I can't find this url in the selection box.


      And at last, when I put the EDI file given by the article in to the receive port, error happened.

      Could anybody please kindly tell me the reason of this error and how to settle it?

      Thank you very much!


    Friday, April 5, 2013 11:08 PM

Answers

All replies

  • Saturday, April 6, 2013 6:19 AM
  • Thank you for your reply.

    I also saw the thread, but I still don't know how to deal with my problem.

    >This eventlog entry is indicative of two possible errors. 

    >The first is the X12 or EDIFACT ServiceSchema is not deployed and the second is that

    >the receive pipeline could not process the incoming interchange,

    >because the Header/control segments in the interchange did not conform to the X12 or >EDIFACT ServiceSchema.

    I used the sample data supplied by the example. I think there will be of no problem the deployment and I don't know

    why the receive pipeline could not process the incoming interchange.

    Saturday, April 6, 2013 8:53 PM
  • Thank U! I found the problem. There are something wrong with my Biztalk enviroment. 

    I tried on another machine, it's OK.

    Monday, April 8, 2013 10:22 PM
  • what was the environment issue with BizTalk ?

    I think I am experiencing same issue.  I have added  BaseArtifacts.dll and still get same  service schema error.

    thanks

    George

    Monday, July 1, 2013 1:49 PM