none
How to use .NET reactor to protect VSTO click-once solution RRS feed

  • Question

  • Has anyone tried protecting VSTO clickonce solution using .NET reactor? I am not exactly sure of the necessary workflow. I use the following:

    1. In Visual Studio, I build the project
    2. Using .NET reactor I encrypt the .dll found in /Project folder/bin/Debug
    3. I create the ClickOnce setup from the Build / Publish menu
    4. After setup, I can easily open the active .dll using .NET reflector

    What am I doing wrong?

    Wednesday, October 15, 2014 8:21 PM

Answers

  • I have received this reply from support@eziriz.com - it works!

    You can use .NET Reactor on a ClickOnce deployment project the following way:<o:p></o:p>

    <o:p> </o:p>

    - Open .NET Reactor and install the Visual Studio Add-in (.NET Reactor main menu item Help -> Install Visual Studio 20XX Add-In).<o:p></o:p>

    - Open your Visual Studio project and open the Add-in (Visual Studio main menu item Tools -> .NET Reactor).<o:p></o:p>

    - Check "Enabled"<o:p></o:p>

    - Check "Project  Output Is Part Of A Deployment Project (Setup, ClickOnce)"<o:p></o:p>

    - You can define the protection settings by defining the .NET Reactor project file or via command line switches<o:p></o:p>

    - Click OK and allow .NET Reactor to modify your Visual Studio project file<o:p></o:p>

    <o:p> </o:p>

    This way a the Visual Studio project file is modified in a way to access .NET Reactor at the right time (after your software is compiled but still before it is packed).<o:p></o:p>

    <o:p> </o:p>

    In your case the problem is probably caused by a specific part of the Anti ILDASM option, which is enabled by default. Please enable Anti ILDASM and disable "2. Protection Settings"->"Anti ILDASM / Suppress Decompilation"->"Inject Invalid Metadata". If you want to disable it using command line parameter please use: -invalid_metadata 0<o:p></o:p>

    Thursday, October 16, 2014 7:27 AM

All replies

  • Hi,

    As far as I know, NET Reactor is a powerful code protection and software licensing system for software written for the .NET Framework, and supports all languages that generate.

    Since it is a 3rd-party system and we are not familiar with its features, for the questions about NET Reactor, I suggest you posting in the official website of NET Reactor for more effective responses.

    Thanks for your understanding.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, October 16, 2014 2:09 AM
    Moderator
  • Make sure that you encrypt assemblies each time you build the add-in. For example, Post-Build actions can be used for running the obfuscator. Most probably the add-in is built anew when you are publishing it. Is that the case?
    Thursday, October 16, 2014 7:21 AM
  • I have received this reply from support@eziriz.com - it works!

    You can use .NET Reactor on a ClickOnce deployment project the following way:<o:p></o:p>

    <o:p> </o:p>

    - Open .NET Reactor and install the Visual Studio Add-in (.NET Reactor main menu item Help -> Install Visual Studio 20XX Add-In).<o:p></o:p>

    - Open your Visual Studio project and open the Add-in (Visual Studio main menu item Tools -> .NET Reactor).<o:p></o:p>

    - Check "Enabled"<o:p></o:p>

    - Check "Project  Output Is Part Of A Deployment Project (Setup, ClickOnce)"<o:p></o:p>

    - You can define the protection settings by defining the .NET Reactor project file or via command line switches<o:p></o:p>

    - Click OK and allow .NET Reactor to modify your Visual Studio project file<o:p></o:p>

    <o:p> </o:p>

    This way a the Visual Studio project file is modified in a way to access .NET Reactor at the right time (after your software is compiled but still before it is packed).<o:p></o:p>

    <o:p> </o:p>

    In your case the problem is probably caused by a specific part of the Anti ILDASM option, which is enabled by default. Please enable Anti ILDASM and disable "2. Protection Settings"->"Anti ILDASM / Suppress Decompilation"->"Inject Invalid Metadata". If you want to disable it using command line parameter please use: -invalid_metadata 0<o:p></o:p>

    Thursday, October 16, 2014 7:27 AM