none
.NET Framework 3.5 crashes when trying to install RRS feed

  • Question

  • Hello there, I'm trying to install .NET Framework 3.5 but it suddenly crashes, I've tried to install it by downloading it from the microsoft page, and by trying to install visual studio 2008, everything fails.
    the error I get is the following (sorry it has some parts in spanish):

    Descripción:
      Microsoft Visual Studio 2008 Professional Edition - ENU has encountered a problem during setup. 
    Setup did not complete correctly.

    Firma con problemas:
      Nombre del evento de problema:    VisualStudio8Setup
      Firma del problema 01:    247
      Firma del problema 02:    9.0.21022.08_ORCAS_X86_NET
      Firma del problema 03:    PR
      Firma del problema 04:    INST
      Firma del problema 05:    F
      Firma del problema 06:    gencomp710,{168d82f8-ac6b-4b55-804f-2ae51ac4b
      Firma del problema 07:    BASERET_UNKNOWN
      Firma del problema 08:    -
      Firma del problema 09:    1
      Firma del problema 10:    -
      Versión del sistema operativo:    6.0.6000.2.0.0.256.1
      Id. de configuración regional:    2058

    Información adicional del problema:
      LCID:    1033

    Lea nuestra declaración de privacidad:
      http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0c0a


    I've googled and tried different ways to install it for more than 8 hours and I still can't find the solution, I'd really appreciate if you could help me.

    Thanks.


    Monday, May 19, 2008 5:53 AM

Answers

  • Thanks Figo, I've already looked and tried all the links you provided, without luck, so I decided to format & reinstall my vista, after that it worked, maybe registry was corrupted.

    Thanks anyway!

     

    Thursday, May 22, 2008 2:22 PM

All replies

  • I'd like to post also the error log of the file %temp%\dd_dotnetfx35error.txt:

    [05/19/08,23:17:11] Microsoft .NET Framework 2.0SP1 (CBS): [2] Error: Installation failed for component Microsoft .NET Framework 2.0SP1 (CBS). MSI returned error code 1
    [05/19/08,23:17:21] WapUI: [2] DepCheck indicates Microsoft .NET Framework 2.0SP1 (CBS) is not installed.

    I've really have searched and found many people with the exact same problem, I've tried the soulutions that worked for them but none has worked for me. Also i ran the tool:
    http://blogs.msdn.com/aaronru/archive/2007/11/29/net-framework-3-5-installation-validation-tool.aspx

    Here's the result:

    WINDOWS VERSION: 6.0.6000
    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\x86_netfx-mscorwks_dll_b03f5f7
    f11d50a3a_6.0.6000.16385_none_3288e9602e8b1a83\mscorwks.dll"
    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\msil_presentationframework_31b
    f3856ad364e35_6.0.6000.16385_none_747fd3bef712914d\PresentationFramework.dll"
    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\x86_wpf-presentationframework_
    31bf3856ad364e35_6.0.6000.16385_none_6c4e99c0590c3d7e\PresentationFramework.dll"

    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\msil_system.servicemodel.ref_b
    77a5c561934e089_6.0.6000.16385_none_6c916732125c43c8\System.ServiceModel.dll"
    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\msil_system.servicemodel_b77a5
    c561934e089_6.0.6000.16385_none_a515e4fe8a4dbcc1\System.ServiceModel.dll"
    ERROR: The following Additional Binaries EXIST in the CSI Store
    ERROR: The Additional Package: "C:\Windows\winsxs\x86_wcf-system.servicemodel_b0
    3f5f7f11d50a3a_6.0.6000.16385_none_15244c8eeb1cc379\System.ServiceModel.dll"
    POTENTIAL ERROR: REGISTRYDUMP: reg query "HKLM\SOFTWARE\Microsoft\NET Framework
    Setup\NDP\v2.0.50727" /v "SP"

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v2.0.50727
        SP    REG_DWORD    0x0

    ERROR: NetFx2.0 SP1 is not installed
    POTENTIAL ERROR: REGISTRYDUMP: reg query "HKLM\SOFTWARE\Microsoft\NET Framework
    Setup\NDP\v3.0" /v "SP"


    ERROR: El sistema no ha podido encontrar la clave o el valor del Registro
    especificados.
    ERROR: Netfx3.0 SP1 is not installed
    POTENTIAL ERROR: REGISTRYDUMP: reg query "HKLM\SOFTWARE\Microsoft\NET Framework
    Setup\NDP\v3.5" /v "Install"
    ERROR: El sistema no ha podido encontrar la clave o el valor del Registro
    especificados.
    ERROR: Netfx3.5 RTM is not installed


    It looks like there are MANY errors on my system, I really appreciate your help.
    Tuesday, May 20, 2008 4:42 AM
  • Error code 1 means the package is not applicable on the system, due to beta product or corrupted registry: http://blogs.msdn.com/astebner/archive/2007/08/24/4548657.aspx
    And related Thread: http://forums.microsoft.com/MSDN/ShowPost.aspx?PostID=2658411&SiteID=1

     

    Hope it helps, if it fails again please follow What to do when you go to post a setup and deployment issue on the MSDN forums?
    http://blogs.msdn.com/aaronru/archive/2007/12/10/what-to-do-when-you-go-to-post-a-setup-and-deployment-issue-on-the-msdn-forums.aspx

     

    Thanks


    Wednesday, May 21, 2008 6:28 AM
  • Thanks Figo, I've already looked and tried all the links you provided, without luck, so I decided to format & reinstall my vista, after that it worked, maybe registry was corrupted.

    Thanks anyway!

     

    Thursday, May 22, 2008 2:22 PM