none
Blob 'https://peakstorage1.blob.core.windows.net/adf-data/sales/2016/06' does not exist.

    Question

  • Im using a EDX training course to try and get up to speed a little with data factory. 

    I have blob storage connected to a folder adf-data/sales/2016/06

    and there are text files with dates for example 01.txt This worked fine when I did the csv files but now I'm getting the above error trying to import txt files. Could the error be that I have the wrong column delimiter in my file. This is the only thing I can think that this error might relate to.

    Any help would be really appreciated

    Thanks

    Debbie

    Friday, September 28, 2018 7:46 AM

Answers

  • Hi it was the fact that my column delimiter was wrong so all sorted

    It should be this

    "published": false,
    "type": "AzureBlob",
    "linkedServiceName": "blob-store",
    "typeProperties": {
    "fileName": "{Day}.txt",
    "folderPath": "adf-data/sales/{Year}/{Month}",
    "format": {
    "type": "TextFormat",
    "columnDelimiter": "\t",
    "firstRowAsHeader": true

    • Marked as answer by Debbie Edwards Friday, September 28, 2018 10:56 AM
    Friday, September 28, 2018 10:56 AM

All replies

  • Hi Debbie,

    Would you please provide us with the dataset json definition which encountered the error? What's the folderPath and fileName setting? Column delimiter should not cause the above error. Please ensure the files you designated in folderPath and filename do exist.

    Thanks.

    Friday, September 28, 2018 8:33 AM
  • Hi it was the fact that my column delimiter was wrong so all sorted

    It should be this

    "published": false,
    "type": "AzureBlob",
    "linkedServiceName": "blob-store",
    "typeProperties": {
    "fileName": "{Day}.txt",
    "folderPath": "adf-data/sales/{Year}/{Month}",
    "format": {
    "type": "TextFormat",
    "columnDelimiter": "\t",
    "firstRowAsHeader": true

    • Marked as answer by Debbie Edwards Friday, September 28, 2018 10:56 AM
    Friday, September 28, 2018 10:56 AM