locked
ModalPopupExtender selects background and looses focus RRS feed

  • Question

  • User1886661451 posted

    On a webform with an updatepanel I use multiple ModalPopupExtenders. This worked perfectly until I rRecently I installed the new version of the AjaxControlToolkit (version 15).

    Since then, when I click a button (not the first time, not the second, but the third time) the background gets selected, the popup looses focus and I can't do anything anymore on my page.

    Code and screendumps can be downloaded from www.doppio-l.nl/bestanden/ProblemWithPopUp.zip.

    The popups need to be within the panel, because one popup on postback fills the others.

    Who can help me?

    Wednesday, March 16, 2016 11:23 AM

Answers

  • User61956409 posted

    Hi EllenHeijmans,

    Since then, when I click a button (not the first time, not the second, but the third time) the background gets selected, the popup looses focus and I can't do anything anymore on my page.

    It seems that the stack order of elements are changed, so please use F12 developer tools to check the z-index property of the modal and overlay, and you could set a custom CSS style for modal to specify a greatest stack order.

    Best Regards,

    Fei Han

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 17, 2016 2:30 AM

All replies

  • User61956409 posted

    Hi EllenHeijmans,

    Since then, when I click a button (not the first time, not the second, but the third time) the background gets selected, the popup looses focus and I can't do anything anymore on my page.

    It seems that the stack order of elements are changed, so please use F12 developer tools to check the z-index property of the modal and overlay, and you could set a custom CSS style for modal to specify a greatest stack order.

    Best Regards,

    Fei Han

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 17, 2016 2:30 AM
  • User1886661451 posted

    Hi Fei,

    Thanks for your answer. I have changed the style in my css to "z-index:1000 !important" The popup now remains clickable, so that's a relief. But the background also remains clickable. So I can select from a combobox in the background etc. (the color becomes white instead of grey as it was when the first popop popped up).

    Can this be helped as well?  

    Thursday, March 17, 2016 3:53 PM
  • User1886661451 posted

    Found it. I have now changed the z-index for the ModalPopupExtender to 999 and for the panel in it to 1000. It works!

     

    Thursday, March 17, 2016 3:58 PM