locked
Unable to open SharePonint 2010 site in SharePoint Designer 2010 even I have full control access. RRS feed

  • Question

  • Unable to open SharePonint 2010 site in SharePoint Designer 2010 even I have full control access.

    I am getting below error

    "Microsoft Share point designer does not support editing non share point sites."

    Friday, January 25, 2013 11:44 AM

Answers

  • Hi,

    Many peoples solve this problem juts closing the designer and reopen it. you can also try it. You can also try this KB article:

    http://support.microsoft.com/kb/981223

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by star.wars Friday, February 1, 2013 9:08 AM
    Friday, January 25, 2013 12:07 PM
  • Hi Manikandan,

    Could you try verifying the settings under Site Collection Administration --> SharePoint Designer Settings. Ensure that this is allowed. Similarly check the Designer settings at Web Application level from Central Administration. Ensure that SharePoint designer usage is allowed at this level too.

    Also, if you are using a custom Site definition, there is a non configurable setting to disable usage of SharePoint designer which means a permanent disabling of SharePoint designer usage. This needs to be cross checked with the administration team.


    Best Regards, Paramesh.

    • Marked as answer by star.wars Friday, February 1, 2013 9:08 AM
    Friday, January 25, 2013 1:25 PM

All replies

  • Hi,

    Many peoples solve this problem juts closing the designer and reopen it. you can also try it. You can also try this KB article:

    http://support.microsoft.com/kb/981223

    Let us know your result


    Hemendra: "Yesterday is just a memory,Tomorrow we may never see"

    Whenever you see a reply and if you think is helpful, click "Alternate TextVote As Helpful"! And whenever you see a reply being an answer to the question of the thread, click "Alternate TextMark As Answer

    • Marked as answer by star.wars Friday, February 1, 2013 9:08 AM
    Friday, January 25, 2013 12:07 PM
  • Hi Manikandan,

    Could you try verifying the settings under Site Collection Administration --> SharePoint Designer Settings. Ensure that this is allowed. Similarly check the Designer settings at Web Application level from Central Administration. Ensure that SharePoint designer usage is allowed at this level too.

    Also, if you are using a custom Site definition, there is a non configurable setting to disable usage of SharePoint designer which means a permanent disabling of SharePoint designer usage. This needs to be cross checked with the administration team.


    Best Regards, Paramesh.

    • Marked as answer by star.wars Friday, February 1, 2013 9:08 AM
    Friday, January 25, 2013 1:25 PM
  • I too faced the same issue. I was working on the sharepoint designer. And to check the side side by side. I had the site opened in the browsers. 

    Then suddenly  the desinger did not allow me to change the master page . Giving you do not have access to the site error in designer.

    Then I closed all the browser windows in my local machine. 

    the site was hosted on a remote machine with Sharepoint 2010 server. 

    I closed all the instances of the site  remote machine hopign for solution that  too did not work.

    Then, I reset the iis also. may be the app pool was corrupt

    But above did not work. 

    Then I did what usually people are not allowed to do. 

    I restarted the remote machine and my local machine and then again tried to open the site and that worked. 

    May be this helps you. I think the issue came because i had logged in my local  machine with many accounts across browsers . Some of them did not have permissions. 

    So may be that corroupted it. 

    Hope this helps you.... :) 

    REgards

    Vinod

    Friday, December 13, 2013 1:32 PM