none
Can't work, new VS 2017community install on new Dell Inspirion 13 i7. VS comes up but after Start Page start receiving error messages

    Question


  • appears soon after VS displays Start Page:

    The 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' package did not load correctly.

    examined activitylog.xml

    when I dismiss error dlg (happens twice)

    New Message as IDE displays the Start Page:

    "The 'Microsoft.VisualStudio.Diagnostics.HtmlToolHost.Package.HtmlToolHostPackage, The 'Microsoft.VisualStudio.WebClient.Diagnostics.HtmlToolHost, Version=15.0.0.0, Culture=neutral,
    PublicKeyToken=b03f5f711d50a3a' did not load correctly.

    Tried devenv /resetuserdata with no luck

    Deleted contents of C:\Users\fscah\AppData\Local\Microsoft\VisualStudio\15.0_e0595b18\ComponentModelCache with no result.

    Please help!!

    Tuesday, March 28, 2017 3:20 PM

Answers

  • Joyce,

    So glad you're not giving up!

    Just completed task of downloading VS Community 2017 ISO and installing it on this machine.

    Ran install and received precisely the same error dialog soon after Start Page appears:

    "The 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' package did not load correctly."

    Here's an extract of the errors from ActivityLog. I've saved the full log but it appears there's no way for me to attach a file from this interface.

    Extract:

     Unexpected system error mode before loading package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...
     
     Line 739:     <description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...
     
     Line 739:     <description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...

    Friday, April 14, 2017 3:20 PM
  • Joyce,

    Strange miracle (seeming)!

    I just called Dell Support and the technician (in India) connect remotely and, once on my desktop, opened Visual Studio. The error dialog box stopping me did not appear!! He closed the Visual Studio session and then I tried and succeeded.

    I've now been working for several hours and all is working beautifully.

    I don't understand but maybe the solution was a result of following your lead to install from an ISO and yet some very local buffer of initial data for VS startup wasn't flushed until working from the remote connection refreshed it????

    I'm marking this answered and thank you profusely for your persistence.

    F. Scott Cahill

    Friday, April 14, 2017 5:24 PM

All replies

  • Hi,

    Welcome to MSDN forum.

    Please try the steps below:

    • Launch “Developer Command Prompt for VS 2017” as Administrator
    • Go to VS 2017 installation folder, for example: pushd C:\Program Files (x86)\Microsoft Visual Studio\2017\Enterprise
    • gacutil -if Common7\IDE\PublicAssemblies\Microsoft.VisualStudio.Shell.Interop.8.0.dll

    Refer: https://developercommunity.visualstudio.com/content/problem/30312/problems-when-starting-vs-2017-enterprise-on-windo.html

    If the issue persists, please use http://aka.ms/vscollect to gather the installation logs. After using it, you will find vslogs.zip under %temp% folder. Please upload the file to https://onedrive.live.com/ and share the link here.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, March 29, 2017 7:32 AM
  • Joyce,

    My problem still unsolved. Can you please update me on status. I saw it change from 'new' to 'triaged' but I don't know what that means. I uploaded the activity log zip from Collect.

    I've had to retreat to my old laptop, an Acer running windows 10 on an i7 core and VS 2017 Community runs fine, thus, it must be the new machine, Dell Inspiron 13 i7 7th gen running Windows 10 professional where the problem arises.

    Friday, March 31, 2017 4:33 PM
  • Hi,

    >>I saw it change from 'new' to 'triaged' but I don't know what that means.

    Sorry to that, If your issue was post in https://developercommunity.visualstudio.com/spaces/8/index.html, we couldn’t change the status.

    Besides, you could uninstall visual studio 2017 by the following steps:

    1. Go to Control Panel—Programs and Features, if there has ‘Microsoft Visual Studio 2017’, right click it and choose ‘Uninstall’

    2. Try to delete the following installed folders: (you can back up those folders before any modification, in case we need to roll back)

    • Go to the folder: %ProgramData%\Microsoft\VisualStudio and delete the ‘Packages’ folder and ‘Setup’ folder if there has.
    • Go to the Visual Studio installation folder (normally under %ProgramFiles(x86)%\Microsoft Visual Studio) and delete the folder ‘2017’

    After this, reinstall it.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 3, 2017 8:08 AM
  • Joyce,

    Thanks so much for hanging in with me! I followed steps exactly as you indicated.

    -Uninstall

    -delete VS folders

    -reinstall

    I open VS; arrive at Start Page and several seconds later same error appears.

    -I close VS; open cmd prompt, gac Interop dll exactly as indicated and receive confirmation that assembly was successfully moved.

    I open VS and it errors out!

    Here's the specific activitylog error:

      <record>5507</record>
        <time>2017/04/05 15:34:50.959</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>LegacySitePackage failed for package
     [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]
     Source: &apos;mscorlib&apos; Description:
     The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\s5lxvl2l.m2x&apos;
     because it is being used by another process.&#x000D;&#x000A;System.IO.IOException:
     The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\s5lxvl2l.m2x&apos;
     because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode,
     String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;  
     at System.IO.File.Delete(String path)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A; 
     at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.VsExportProviderFactoryWorker.&lt;
     GetCurrentAssemblyCatalogsAsync&gt;d__15.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A; 
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A; 
     at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.VsExportProviderFactoryWorker.&lt;&gt;
     c__DisplayClass13_0.&lt;&lt;GetCurrentAssemblyCatalogsAsync&gt;b__1&gt;d.MoveNext()  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;GetExportProviderFactoryAsync&gt;d__35.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.&lt;GetMEFV3ExportProviderInternalAsync&gt;d__50.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.&lt;GetMEFV3ExportProviderWrapperAsync&gt;d__49.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Threading.AsyncLazy`1.&lt;&gt;c__DisplayClass13_1.&lt;&lt;GetValueAsync&gt;b__0&gt;d.MoveNext()&#x000D;&#x000A;
     --- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task)&#x000D;&#x000A;  
     at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Threading.JoinableTask.CompleteOnCurrentThread()&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Threading.JoinableTask`1.CompleteOnCurrentThread()&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Threading.JoinableTaskFactory.Run[T](Func`1 asyncMethod, JoinableTaskCreationOptions creationOptions)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Threading.JoinableTaskFactory.Run[T](Func`1 asyncMethod)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetLazyValue[T](AsyncLazy`1 lazy)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.ComponentModelHost.ComponentModel.GetService[T]()&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Editor.Implementation.EditorParts.get_ContentTypeRegistryService()&#x000D;&#x000A; 
     at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper
     .MakeLanguageServiceContentTypes(SettingsStore settingsStore)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Editor.Implementation.LanguageServiceToContentTypeMapper.
     InitLanguageServiceToContentTypeMapper(IServiceProvider serviceProvider)&#x000D;&#x000A;  
     at Microsoft.VisualStudio.Editor.Implementation.EditorPackage.Initialize()&#x000D;&#x000A; 
     at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.Shell.Interop.IVsPackage.SetSite(IServiceProvider sp)
     </description>
        <guid>{E269B994-EF71-4CE0-8BCD-581C217372E8}</guid>
        <hr>80070020</hr>

    Please keep helping me!!

    Wednesday, April 5, 2017 4:14 PM
  • Hi,

    After you use :gacutil -if Common7\IDE\PublicAssemblies\Microsoft.VisualStudio.Shell.Interop.8.0.dll, it should get the following screenshots.

    >>The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\s5lxvl2l.m2x&apos;

      because it is being used by another process.&#x000D;&#x000A;System.IO.IOException:

      The process cannot access the file

    Please go to C:\Users\fscah\AppData\Local\Temp\s5lxvl2l.m2x&apos and right click it->properties->security, and then make sure that the current account you used to log in computer has full control.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 6, 2017 9:10 AM
  • Joyce,

    Again, thanks for sticking with this!

    I most assuredly got the message 'assembly added...' when I 'gacted' the interop dll.

    The file you point out, Temp\s5lxvl2l.m2x properties say that my log-in has full control.

    I check properties on the folder 'Temp' which also says I have full control but it also has the 'readonly' attribute marked. I tried setting the folder to read-write and a little dialog appears the seems to be making that change to the children but if I close the folder and return it's again marked read-only.

    These property manipulations remind me to report that this new Dell Inspirion 13 CORE I7-7500U  is running on Windows 10 Pro. Does 'Pro' require some extra setup? My Acer which runs VS2017 just fine is running on Windows10 but not Windows 10 Pro.

    F. Scott

    Thursday, April 6, 2017 4:03 PM
  • Dear F.Scott,

    Here is the Visual Studio 2017 Product System Requirements:

    you may refer to it and check you windows 10 version.

    Just hope it helps.

    Good luck.

    Best regards.

    Fletch 


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 7, 2017 11:46 AM
  • Joyce,

    My Windows 10 version is 1607.

    Are you giving up on this problem?

    Friday, April 7, 2017 3:13 PM
  • Hi,

    Thank you for your update.

    Please have a look at this: https://developercommunity.visualstudio.com/content/problem/26746/getting-errors-when-starting-vs2017-ide.html if you have installed the other version of visual studio.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, April 10, 2017 9:37 AM
  • Joyce,

    As I stated in the problem submission, this is a brand new machine so it's come no where close to VS2005.

    Please notify me if you've come to the end of your ability to help so I don't have to keep checking this thread.

    The problem is unsolved.

    Tuesday, April 11, 2017 4:59 PM
  • Joyce,

    As I stated in the problem submission, this is a brand new machine so it's come no where close to VS2005.

    Please notify me if you've come to the end of your ability to help so I don't have to keep checking this thread.

    The problem is unsolved.

    Yes but who's problem is it. You tell it only happens on a Dell computer, and nobody is telling it happens on others as well. 

    Maybe contacting Dell don't you think?


    Success
    Cor

    Tuesday, April 11, 2017 5:02 PM
  • I did contact Dell.

    They say the opposite, that I must go to Microsoft for the solution.

    Please don't leave me between a rock and a hard place.

    This Dell machine works fine except Visual Studio 2017 Community will not install properly.

    Wednesday, April 12, 2017 4:51 PM
  • Hi,

    Please create an offline installation of visual studio 2017 on a computer with good network connection: https://docs.microsoft.com/en-us/visualstudio/install/create-an-offline-installation-of-visual-studio, the size of the installation package is more than 20g. after this, copying it to your pc and install it from offline folder.

    Best regards,

    Joyce


    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, April 13, 2017 8:57 AM
  • Joyce,

    So glad you're not giving up!

    Just completed task of downloading VS Community 2017 ISO and installing it on this machine.

    Ran install and received precisely the same error dialog soon after Start Page appears:

    "The 'Microsoft.VisualStudio.Editor.Implementation.EditorPackage' package did not load correctly."

    Here's an extract of the errors from ActivityLog. I've saved the full log but it appears there's no way for me to attach a file from this interface.

    Extract:

     Unexpected system error mode before loading package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]</description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...
     
     Line 739:     <description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...
     
     Line 739:     <description>
     LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;System.IO.IOException: The process cannot access the file &apos;C:\Users\fscah\AppData\Local\Temp\vsmpjjx4.gq3&apos; because it is being used by another process.&#x000D;&#x000A;   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)&#x000D;&#x000A;   at System.IO.File.InternalDelete(String path, Boolean checkHost)&#x000D;&#x000A;   at System.IO.File.Delete(String path)&#x000D;&#x000A;   at Microsoft.VisualStudio.ExtensibilityHosting.VsExportProviderFactory.&lt;SerializeAssemblyCatalogsAsync&gt;d__46.MoveNext()&#x000D;&#x000A;--- End of stack trace from previous location where exception was thrown ---&#x000D;&#x000A;   at System.Runtime.CompilerServices.TaskAwaiter.ThrowF...

    Friday, April 14, 2017 3:20 PM
  • Joyce,

    Strange miracle (seeming)!

    I just called Dell Support and the technician (in India) connect remotely and, once on my desktop, opened Visual Studio. The error dialog box stopping me did not appear!! He closed the Visual Studio session and then I tried and succeeded.

    I've now been working for several hours and all is working beautifully.

    I don't understand but maybe the solution was a result of following your lead to install from an ISO and yet some very local buffer of initial data for VS startup wasn't flushed until working from the remote connection refreshed it????

    I'm marking this answered and thank you profusely for your persistence.

    F. Scott Cahill

    Friday, April 14, 2017 5:24 PM
  • Same Problem.

    About 8 hours over a few days installing, reinstalling uninstalling, running TotalUninstaller as admin ( https://github.com/Microsoft/VisualStudioUninstaller/releases )
    And still VS 2017 falls apart and gives these two messages on launch which, unhelpfully is not copyable as text (but is as you descibe above). In the xml log pointed to by the error message

    1 beginning:
    <source>ClientRights</source>
    <description>Client rights determined: {&quot;CurrentClientRights&quot;:{&quot;ActivityId&quot;:&quot;58e939d9-4e24-4840-834b-01b39a700ab4&quot;,&quot;AuthorizedVsEdition

    and 3 beginning similarly to:
    <source>VisualStudio</source>
    <description>LegacySitePackage failed for package [Microsoft.VisualStudio.Editor.Implementation.EditorPackage]Source: &apos;mscorlib&apos; Description: The process cannot access the file because it is being used by another process.

    I’m using an Asus so it's not just Dell, I AM using a Windows 10 same version as you mention (1607) on a powerful machine, its not new but plenty of goodness. It did have VS 2015 on it hence the TotalUninstaller actions above...

    I’ve tried to find help and similar issues
    Like this guy:
    http://stackoverflow.com/questions/41508475/vs-2017-package-load-errors
    And
    https://connect.microsoft.com/VisualStudio/feedback/details/800087/getting-error-microsoft-visualstudio-editor-implementation-editorpackage-package-did-not-load-correctly 

    I have deleted the directory C:\Users\user\AppData\Roaming\Microsoft\VisualStudio 
    With no positive result. 

    I can’t find anything that doesn’t almost involve opening the computer with a screwdriver and wading in! Is this involving “an incompatible assembly into the GAC” (https://developercommunity.visualstudio.com/content/problem/26746/getting-errors-when-starting-vs2017-ide.html ) I have tried the GAC, no positive result. 

    Lots of restarts and coffee and still nothing. 

    Any suggestions?     

     
    Wednesday, May 17, 2017 1:54 PM