none
VSTO Tools for Office 2012 will not install RRS feed

  • Question

  • I am trying to install VSTO 2012 on a Windows 7 machine and get the following errors.  When I got the access denied error for the file 1343597488.xml.temp I attempted a couple of things.  One was to create a file with these extensions in the folder to see if it then could be accessed and modified by the installer.  No Go.

    Noting that Read Only permissions were set, tried removing them but they reset themselves somehow.

    Since this is an "Access to the path ..." type of error, I believe it should be taken literally and that this is a permissions issue.  We're administrators on our machines at work.  The permissions for the folders have been checked and Full Control with Write Permissions are set both for my account and administrators.

    So I tried moving the Web Installer MSI file and the VSTO 2012 executable out of the .../web platform installer folder to my desktop.  This also didn't work. (Naturally, now that I think back on it. :) )

    I can find no installer issues on Google for the Exe or for the MSI and I can't find otherwise what is wrong.

    It's obvious it's a permissions thing and one of our help desk crew will help me dig into this here but I know enough of Windows administration myself, I think there's some sort of issue with the installer.  And it isn't configurable so different options that probably should be there to troubleshoot issues aren't exposed.

    Thanks for any help.

     


    Michael Durthaler

    Wednesday, March 18, 2015 12:53 PM

Answers

  • Problem solved.

    The issue is the Downloads folder has been locked down by group policy.   This explains why the read only permissions were being reset.

    Simply moving the .exe file to another folder solved the problem but this does not explain why administrator privileged accounts are being overridden.  Clearly with permissions set for full control this should override the read-only checkbox but maybe I recall that wrong. (Admin permissions ought to have precedence that is but maybe group policy can be configured to where even these are preempted)

    To clarify, when the move above was done, it was to the desktop which is still in the .../users/mdurthal/... path.  So it appeared moving the files to another location didn't work but the case here is this path was still affected by the group policy :). Thought I should mention that.

    Should this one bite anyone else just create a new folder off the C:\ drive that isn't affected by such settings.


    Michael Durthaler


    • Marked as answer by SACSgtMike Wednesday, March 18, 2015 1:29 PM
    • Edited by SACSgtMike Wednesday, March 18, 2015 1:55 PM Clarify a point.
    Wednesday, March 18, 2015 1:29 PM