none
Error code 801c0003

    Question

  • I am the Global Administrator for our office 365 account and Azure Active Directory. I am attempting to add a laptop to the Active directory in the installation stage of windows, but I am getting an error code that is saying I do not have permission. I have added computers to the directory before, so I am not sure why I am getting this error. Any help would be appreciated.
    Thursday, April 6, 2017 3:58 PM

All replies

  • Have you tried joining the device after the installation of Windows ?
    The devices that you have joined to Azure AD before, were they at the time of installation or after ?

    Ref: Enroll your Windows 10 device

    Friday, April 7, 2017 10:19 AM
    Moderator
  • Turns out, there is a 15 device CAP on Azure enrollment by a single O365 admin account.  There is a program through Intune that allows up to 1000 devices in a corporate network, but there's a fair gap between 15 devices and an environment large enough to support an Intune account.

    However (this is one of the few times when something good comes after that word),

    Let's say you've been using admin@contoso.com as your global admin account and adding computers to the Azure AD account.  All you have to do is create another, unlicensed Global Admin Account, such as admin2@contoso.com.  Use that to add additional computers until you use up another 15 devices, then create admin3@contoso.com and so forth.

    • Proposed as answer by Jim Bachaud Saturday, April 8, 2017 10:09 PM
    Saturday, April 8, 2017 10:08 PM
  • I have just had this issue in OOBE for a user who is 100% definitely in the group for AAD enroll and is getting 
    801c0003.  Tried on an existing machine (not in OOBE), same error.  Still not resolved...
    Friday, April 28, 2017 4:00 PM
  • I had the same issue (was able to join computers last week, all of a sudden I can't now). Its due to a join limit set by default (default is 20 computers I believe). In Azure AD, go to Users and Groups tab, then under "Manage" go to "Device Settings." Under "Maximum number of devices per user" change that to "unlimited" then save it. In a moment try again and you should be good to go

    Monday, October 30, 2017 8:37 PM
  • Thanks bro!

    Solved for me

    Thursday, March 15, 2018 8:34 AM
  • a huge thanks to you Adrain for this.

    I've been rattling my brain trying to fathom out why i couldn't register even one device.  I'd changed my max to 5, as i assumed/thought this value was the max number a user could have, rather than a single user could register.

    Changed this back to 20 and it added straight away - why on earth can they not change or update the error message to say max devices for this user reached or something that actually explains what is causing the problem - grrrrr

    thanks once again :)



    • Edited by nealgs Tuesday, March 20, 2018 10:48 AM
    Tuesday, March 20, 2018 10:47 AM