Linked Table - Sub-form - Edit Record And Screen Freezes, Access 2016 RRS feed

  • Question

  • All,
    Thanks in Advance. A very very strange one... 
    I am linking to an Oracle Table 1000 Rows, 60 Columns. A Report Inventory. No field is larger than 250.
    Created a Subform Grid, can Add record, and then edit that same record. But, If I move to another record, and attempt to edit and move to another row, form is forzen. 

    Also, tried in a New database in Access 2016 O365, and linked to ORacle DB, and attempted to Add record without form via Table UI. Can Add, but Edit I see same exact issue.

    I have coded similar forms before, and never had this issue before. Any insight or suggestions greatly appreciated. 

    Tried Linking Oracle Table with both ODBC with Oracle Driver and DNSLess Connections for Linked Table. Same issue under both.  Also tried MS for ORacle Driver - same issue. 
    Tried earlier version of MS Access also... 2007... Same issue. 
    Friday, September 16, 2016 4:31 PM


  • Hi Smedvid,

    First I want to tell you that try to decompile your DB and then try again.

    also make sure that you are not trying to access the data or records that is locked for updating.

    the another thing you can try that just copy your table structure to new table.

    and again try to link it with MySQL and try to run it.

    As you had mentioned that you can add but not able to update so I think that it is related with locked record.

    so you can try to set RecordLocks Property.

    RecordLocks Property

    Form.RecordLocks Property (Access)



    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, September 19, 2016 9:51 AM