locked
Backspace key on some WM 6 phone/emulator not deleting characters but going back to previous screen RRS feed

  • Question

  • Hi

    Thanks for trying to help.

    I have this issue for a good while but found no solution.

    I developed an wm application, but when it's deployed on emulator or real phone (wm 6), the backspace key on the SIP does not delete any character in text box, but rather brings application back to previous screen.

    Is there anything I can do to change this strange behaviour?

    Thanks a lot in advance

    Jane

    Thursday, March 25, 2010 9:21 AM

Answers

  • I don't understand, it works for me here. I just created a simple C# project in VS2008 with a couple of forms with textboxes, and the 'back' key on the keyboard works fine, it deletes the characters in the text box. All default settings, didn't change a thing.

    Could you give some details about your application? And like Malleswar asked above, are you handling any keybd events in your app?

    Check this video of the app I created. Is it any different than yours? Are you using some other non-default SIP?


    Prabhu
    www.geekswithblogs.net/techtwaddle

    Thursday, March 25, 2010 12:43 PM

All replies

  • Hi Jane,

    Are you deploying the web mobile application. In that case when focus is not in address bar, probably it takes to previous page.

    If it client based application, have you written any code in key events?

    Regards,

    Malleswar

     

    Thursday, March 25, 2010 10:21 AM
  • So this thread did not help you fix it? Since you never replied back to that thread, I was under the impression that it was fixed...


    Prabhu
    www.geekswithblogs.net/techtwaddle

    Thursday, March 25, 2010 10:54 AM
  • Sorry, I did have so many issues back a while ago, and only get into this now again.

    The application is written in c#, and I did search but only to find that it might be not possible to change SIP behaviour in managed code? I don't know: Is there a way to program SIP in c# at all??

    Thanks a lot to you all for help!

    Thursday, March 25, 2010 11:03 AM
  • I don't understand, it works for me here. I just created a simple C# project in VS2008 with a couple of forms with textboxes, and the 'back' key on the keyboard works fine, it deletes the characters in the text box. All default settings, didn't change a thing.

    Could you give some details about your application? And like Malleswar asked above, are you handling any keybd events in your app?

    Check this video of the app I created. Is it any different than yours? Are you using some other non-default SIP?


    Prabhu
    www.geekswithblogs.net/techtwaddle

    Thursday, March 25, 2010 12:43 PM