locked
arm template for app service RRS feed

  • Question

  • Hello,

    I have been working with ARM templates for about 4 weeks.  I created one for an App service and it works.  However, I do not see how I can add to the arm template to configure items such as platform is 64 bit, or use 2.0 HTTP version.

    I see the application setting icon in VS 2017 but I do not see how that helps

    thanks

    Wednesday, August 15, 2018 5:59 PM

Answers

  • You can add the property ‘use32BitWorkerProcess’ and set value as ‘false’ to use 64-bit platform. For HTTP 2.0, add ‘http20Enabled’.

    You may check the link for sample ARM template format.

    ------------------------------------------------------------------------------------------
    If this answer was helpful, click “Mark as Answer” or “Up-Vote”. To provide additional feedback on your forum experience, click here.

    Wednesday, August 15, 2018 7:37 PM

All replies

  • You can add the property ‘use32BitWorkerProcess’ and set value as ‘false’ to use 64-bit platform. For HTTP 2.0, add ‘http20Enabled’.

    You may check the link for sample ARM template format.

    ------------------------------------------------------------------------------------------
    If this answer was helpful, click “Mark as Answer” or “Up-Vote”. To provide additional feedback on your forum experience, click here.

    Wednesday, August 15, 2018 7:37 PM
  • Hello,

     

    I added the two commands and must not be doing something not correctly.  I thought I was good when I did not see any of the ugly green lines in Visusal studio and felt really good when I saw template is valid – but then I recived the below errors.  I am guessing I have the two commands in the wrong place.

     

     

    I also tried just the word true without quotes and the word true with quotes does not matter.

     now the commands are grayed out via intellisense if that helps.  

    "apiVersion": "2017-06-01",

          "name": "[variables('applicationGatewayName')]",

          "type": "Microsoft.Network/applicationGateways",

          "location": "[parameters('location')]",     

          "dependsOn": [

            "[variables('virtualNetworkName')]",

            "[variables('publicIPAddressName')]"

          ],

          "properties": {

            "httpsonly": "$true",

            "use32BitWorkerProcess": "$false",

            "sku": {

              "name": "[parameters('applicationGatewaySize')]",

              "tier": "WAF",

              "capacity": "[parameters('capacity')]"

            },

            "gatewayIPConfigurations": [

     


    At line:1 char:1

    + New-AzureRmResourceGroupDeployment -Name tier1app -ResourceGroupName  ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception

        + FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDeploymentCmdlet

    New-AzureRmResourceGroupDeployment : 8:14:53 AM - Could not find member 'httpsonly' on object of type 'ApplicationGatewayProperties'. Path 'properties.httpsonly', line 1, position 48.

    At line:1 char:1

    + New-AzureRmResourceGroupDeployment -Name tier1app -ResourceGroupName  ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [New-AzureRmResourceGroupDeployment], Exception

        + FullyQualifiedErrorId : Microsoft.Azure.Commands.ResourceManager.Cmdlets.Implementation.NewAzureResourceGroupDeploymentCmdlet

    New-AzureRmResourceGroupDeployment : 8:14:53 AM - Could not find member 'use32BitWorkerProcess' on object of type 'ApplicationGatewayProperties'. Path 'properties.use32BitWorkerProcess', line 1, position 80.

    At line:1 char:1

    + New-AzureRmResourceGroupDeployment -Name tier1app -ResourceGroupName  ...

     


    Thursday, August 16, 2018 12:24 PM
  • some more info

    VERBOSE: Performing the operation "Creating Deployment" on target "app101-IAM-Prod-Web-rg".

    VERBOSE: 8:14:35 AM - Template is valid.

    VERBOSE: 8:14:37 AM - Create template deployment 'tier1app'

    VERBOSE: 8:14:37 AM - Checking deployment status in 5 seconds

    VERBOSE: 8:14:42 AM - Checking deployment status in 5 seconds

    VERBOSE: 8:14:48 AM - Resource Microsoft.Network/virtualNetworks 'app101-IAM-Prod-Web-Appgw-01-vnet' provisioning status is succeeded

    VERBOSE: 8:14:48 AM - Resource Microsoft.Network/publicIPAddresses 'app101-IAM-Prod-Web-Appgw-01-Ip' provisioning status is succeeded

    Thursday, August 16, 2018 12:24 PM
  • opps...I set this up in the gateway NOT the app service.  The use HTTP only works but the use32bitworkerprocess was ignored   When I check in the portal is it still 32 bit

    "name": "[variables('app101-IAM-prod-web-IAM-appsvc-01Name')]",

          "type": "Microsoft.Web/sites",

          "location": "eastus2",

          "apiVersion": "2015-08-01",

          "dependsOn": [ ],

          "tags": {

            "[concat('hidden-related:', resourceId(parameters('serverFarmResourceGroup'), 'Microsoft.Web/serverFarms', parameters('serverFarmName')))]": "Resource",

            "displayName": "app101-IAM-prod-web-IAM-appsvc-01"

          },

          "properties": {

            "httpsonly": true,

            "use32BitWorkerProcess": false,

            "name": "[variables('app101-IAM-prod-web-IAM-appsvc-01Name')]",

            "serverFarmId": "[resourceId(parameters('serverFarmResourceGroup'), 'Microsoft.Web/serverFarms', parameters('serverFarmName'))]"

          }

    Thursday, August 16, 2018 12:53 PM
  • Got it to work..for the 64 option to take I had to add  site config first.  

    This link has the info

    http://wp.sjkp.dk/arm-templates-set-always-on-and-other-site-properties/

    thanks

    Thursday, August 16, 2018 1:00 PM
  • Glad to hear that your issue is resolved. Appreciate for sharing the steps which helped you, this would certainly benefit other community members.

    Thursday, August 16, 2018 4:45 PM