none
The report definition is not valid for 2008 schema in VS 2010 RRS feed

  • Question

  • I am using VS 2010, and I have installed .net 4.0. However, when I created winForm application with a reportviewer control (the version is indeed 10.0) in it and built it, I still got the following error : " The report definition is not valid.  Details: The report definition has an invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded." Could somebody help with this issue? From the forum, it seems that VS 2010 supports local processing mode of report viewer control, but I cannot make it work.

    Thanks

    Monday, February 7, 2011 5:27 PM

All replies

  • I have not been able to reproduce this, would you be willing to provide the following information to help debug the issue:

    1. What OS are you on? 
    2. What version of VS 2010 are you using (Express, Pro, Ultimate ...)?
    3. Do you have VS 2008 or the ReportViewer 2008 Redist installed?
    4. Are you getting this error at runtime or when you try to open the report in the Report Designer?

    Matt M.


    This posting is provided "AS IS" with no warranties, and confers no rights

    Monday, February 7, 2011 11:17 PM
  • Hi Matt,

    Thank you for your reply.

    1. XP

    2. Ultimate

    3. Yes, I installed VS 2008 before VS 2010. (maybe I should uninstall it?)

    3. During the compilation.

    Thanks

    Mike

     

    Tuesday, February 8, 2011 4:52 PM
  • OK. After I unstalled VS 2008 redistributable and reinstalled VS 2010, the build worked.

    Wednesday, February 9, 2011 2:44 PM
  • Thanks for the update, however if you don't mind I have a couple more questions.

    1. Did you have the full version of VS2008 installed or did you just have the ReportViewer 2008 redistributable installed?
    2. The projects that you were getting the error with, were they new projects or ones that were upgraded from VS2008/2005?
    3. Did you get the compilation error if you created a brand new WinForms Report project?

    The most likely culprit of the issue is that the 9.0 version of the control was getting loaded in memory versus the 10.0 version; since the 9.0 version uses the 2005 RDL schema it would give you the upgrade error. As I mentioned before I haven't been able to reproduce a scenario that would cause this though. Thanks for your help.

    Matt M.


    This posting is provided "AS IS" with no warranties, and confers no rights

    Wednesday, February 9, 2011 7:11 PM
  • 1. I installed the full version of VS 2008 before, when I tried to uninstall it, I found only VS 2008 redistributable (seems two versions) left in Add/Remove programs (maybe I uninstalled the full version of VS 2008 some time before). What I did was: 1) uninstalled two versions of VS 2008 redistributable 2) uninstalled VS 2010 3) uninstalled .net framework 4.0 4) reinstalled .net framework 4.0 5) reinstalled VS 2010. I think one version of VS 2008 redistributable is the culprit.

    2. A new project in VS2010

    3. Yes.

     

    Mike

    Thursday, February 10, 2011 4:08 PM