none
compatibilty of dll developed in 2.0 to 1.1 RRS feed

  • Question

  • hai,
         i have a problem. i developed a dll in visual studio 2005 and converted it to COM dll. when i include the dll in visual basic 6, the system also has .net framework 1.1 i get an error 'runtime error -2147024894'. It does not detect the object itself. Is it the problem wit compatibility? Or something else should be installed. Please do help me.
    Wednesday, April 8, 2009 11:10 AM

Answers

  • hai,
         Thank you......i found the error actually what the problem is my dll got registered but it was not added in the cache so when i call using an object. Vb did not identify the object. thus i added to cache through gacutil and now am able to use it.

    Thanks and Regards
    Meenu
    • Marked as answer by meenug Friday, April 10, 2009 9:43 AM
    Friday, April 10, 2009 9:42 AM

All replies

  • Hi Meenug,

    More clarification with you. Do you mean that you want to know how to use Microsoft Visual Basic .NET or Microsoft Visual Basic 2005 to build a managed assembly that can be called from Microsoft Visual Basic 6.0?

    If yes, here is a useful KB that shows you the guidelines to call a Visual Basic .NET or Visual Basic 2005 assembly from Visual Basic 6.0.
    See: http://support.microsoft.com/kb/817248/en-us

    Thanks
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Friday, April 10, 2009 8:36 AM
  • hai,
         Thank you......i found the error actually what the problem is my dll got registered but it was not added in the cache so when i call using an object. Vb did not identify the object. thus i added to cache through gacutil and now am able to use it.

    Thanks and Regards
    Meenu
    • Marked as answer by meenug Friday, April 10, 2009 9:43 AM
    Friday, April 10, 2009 9:42 AM