locked
BizTalk Server and BizTalk Adapter Pack RRS feed

  • Question

  • We were so far using a 3rd party adapter for Oracle with BizTalk 2006 (Not R2). We would like to migrate to AdapterPack as we belwive it has all the featires required for us.

    1. We don't have Software Assurance program with Microsoft. Do we have to pay for Adapter Pack? I guess, it is licensed per processor. How much it would approximately cost me?

    2. Will Adapter Pack v1.0/v2.0 work with BizTalk 2006 OR upgrading to 2006 R2 is a must ?

    3. If i must upgrade to BizTalk 2006 R2 , I can as well upgrade to BizTalk 2009. In that case, do is till  have to pay for Adapter Pack v2.0 or is it part of BizTalk 2009?

    All responses will be much appreciated.

    Thanks
    --Jawahar

    Wednesday, March 3, 2010 10:03 PM

Answers

All replies

  • Hi Jawahar,

    To answer your questions:

    1) Adapter Pack 2.0 ($ 5000 US): http://www.microsoft.com/biztalk/en/us/pricing-licensing.aspx
    2) Adapter Pack 1.0/2.0 will work with BizTalk Server 2006 R2 and 2009 requires the WCF LOB Adapter SDK http://msdn2.microsoft.com/en-us/subscriptions/aa718661.aspx. Note: Adapter Pack 2.0 contains all the adapters including the ones from 1.0 version: http://www.microsoft.com/biztalk/en/us/adapter-pack.aspx
    3) If you upgrade to BizTalk 2009 you will not have to pay for the license of Adapter Pack: http://www.microsoft.com/biztalk/en/us/pricing-licensing.aspx.

    In your case an upgrade to 2009 would be best way forward. You benefit from new features in BizTalk 2009 (aligned with 2008 Platform: OS, SQL Server and Visual Studio) and have the Adapter Pack 2.0 available with latest SQL Adapter! You will find a lot of information via Microsoft BizTalk site: http://www.microsoft.com/biztalk/en/us/default.aspx look for Product information.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    Regards, Steef-Jan Wiggers MCTS BizTalk Server http://soa-thoughts.blogspot.com/ If this answers your question please mark it accordingly
    Thursday, March 4, 2010 12:48 AM
  • Thanks for your response. Can we colcude that the Adapter Pack cannot be used with BizTalk 2006(Not R2)?

    So, I must upgrade to either R2 ro 2009 to use Adapter Pack. If i upgrade to R2, i have to pay for the adapter pack and not in the case of 2009.

    Is my understanding correct?

    Thanks
    --Jawahar

    Thursday, March 4, 2010 3:23 PM
  • Hi,

    Your conclusion around adapter pack does not support BizTalk Server 2006 is right, you will then have use old BizTalk Enterprise Adapter (i.e. non-WCF). You can read my article on BizTalk Hotrod Magazine (http://biztalkhotrod.com/Documents/Issue8_Q4_2009.pdf). So yes you will have to upgrade to either 2006 R2 or 2009. Both cases having full licensed BizTalk version you get adapter pack with it (so what you read for 2009 including adapter pack in the links I provided also counts for 2006 R2). I do not believe you will have to pay seperate in case of BizTalk 2006 R2.

    Regards,

    Steef-Jan Wiggers
    MCTS BizTalk Server
    http://soa-thoughts.blogspot.com/
    If this answers your question please mark it accordingly


    Regards, Steef-Jan Wiggers MCTS BizTalk Server http://soa-thoughts.blogspot.com/ If this answers your question please mark it accordingly
    Thursday, March 4, 2010 7:56 PM